# CVE-2021-41090: Instance config inline secret exposure

> Unauthenticated attackers can read plaintext inline secrets from Grafana Agent configuration endpoints, potentially compromising telemetry credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9c4x-5hgq-q3wh, GO-2022-0305

## What is CVE-2021-41090?

CVE-2021-41090 is a medium-severity vulnerability in grafana agent, published on 8 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grafana Agent is a telemetry collector for sending metrics, logs, and trace data to the opinionated Grafana observability stack. Prior to versions 0.20.1 and 0.21.2, inline secrets defined within a metrics instance config are exposed in plaintext over two endpoints: metrics instance configs defined in the base YAML file are exposed at `/-/config` and metrics instance configs defined for the scraping service are exposed at `/agent/api/v1/configs/:key`. Inline secrets will be exposed to anyone being able to reach these endpoints. If HTTPS with client authentication is not configured, these endpoints are accessible to unauthenticated users. Secrets found in these sections are used for delivering metrics to a Prometheus Remote Write system, authenticating against a system for discovering Prometheus targets, and authenticating against a system for collecting metrics. This does not apply for non-inlined secrets, such as `*_file` based secrets. This issue is patched in Grafana Agent versions 0.20.1 and 0.21.2. A few workarounds are available. Users who cannot upgrade should use non-inline secrets where possible. Users may also desire to restrict API access to Grafana Agent with some combination of restricting the network interfaces Grafana Agent listens on through `http_listen_address` in the `server` block, configuring Grafana Agent to use HTTPS with client authentication, and/or using firewall rules to restrict external access to Grafana Agent's API.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-41090?

3 open source packages ship an affected version, including github.com/grafana/agent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/agent` | Go | From 0.14.0 | 0.21.2 |
| `github.com/grafana/agent` | Go | From 0.14.0 | 0.21.2 |
| `github.com/grafana/agent` | Go | From 0.14.0 | 0.21.2 |

Products: Grafana Agent.

## How do I fix CVE-2021-41090?

Upgrade github.com/grafana/agent to 0.21.2 or later.

## Is CVE-2021-41090 being exploited?

There is no known exploitation of CVE-2021-41090 in the wild and no public exploit code.

## Other vulnerabilities in grafana agent

- [CVE-2024-8996](https://insights.sbomify.com/CVE-2024-8996/): Grafana Agent Flow on Windows Unquoted service path (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41090 and fix it if it is affected.

What it is: CVE-2021-41090 is a medium-severity vulnerability in grafana agent, published on 8 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41090 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/agent (Go): affected from 0.14.0; fixed in 0.21.2
- github.com/grafana/agent (Go): affected from 0.14.0; fixed in 0.21.2
- github.com/grafana/agent (Go): affected from 0.14.0; fixed in 0.21.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41090/ (Markdown: https://insights.sbomify.com/CVE-2021-41090/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41090
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41090
- OSV: https://osv.dev/vulnerability/CVE-2021-41090

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41090/
Summaries are generated and may contain mistakes; the official description above is the record.
