{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41098 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.12.5 or later.","what":"CVE-2021-41098 is a high-severity vulnerability in sparklemotion nokogiri, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41098 and fix it if it is affected.\n\nWhat it is: CVE-2021-41098 is a high-severity vulnerability in sparklemotion nokogiri, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41098 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.12.5\n- nokogiri (RubyGems): affected all versions; fixed in 1.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41098/ (Markdown: https://insights.sbomify.com/CVE-2021-41098/index.md)","id":"CVE-2021-41098","markdown":"https://insights.sbomify.com/CVE-2021-41098/index.md","name":"CVE-2021-41098","record":{"aliases":["GHSA-2rr5-8q37-2w7h","OESA-2021-1396","openSUSE-SU-2024:11577-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML parser","requires_auth":"none","summary":"An attacker can exploit an XML External Entity vulnerability in Nokogiri on JRuby to read files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nokogiri","vendor":"nokogiri"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default. Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected: Nokogiri::XML::SAX::Parse, Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser, Nokogiri::XML::SAX::PushParser, and Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser. JRuby users should upgrade to Nokogiri v1.12.5 or later to receive a patch for this issue. There are no workarounds available for v1.12.4 or earlier. CRuby users are not affected.","ecosystems":["RubyGems","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby","id":"CVE-2021-41098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xxe","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Integer overflow issue with strings in Redis","id":"CVE-2021-41099"},"packages":[{"ecosystem":"RubyGems","fixed":["1.12.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-2rr5-8q37-2w7h"},{"ecosystem":"RubyGems","fixed":["1.12.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-2rr5-8q37-2w7h"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.12.5-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-nokogiri","purl":"pkg:rpm/opensuse/rubygem-nokogiri\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11577-1"}],"prev":{"headline":"Prototype pollution in aurelia-path","id":"CVE-2021-41097"},"products":["nokogiri"],"published":"2021-09-27","related":[{"cvss_score":8.7,"headline":"Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer","id":"CVE-2026-79770","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":7.5,"headline":"Unchecked return value from xmlTextReaderExpand in Nokogiri","id":"CVE-2022-23476","kev_date_added":null,"published":"2022-12-08"},{"cvss_score":7.5,"headline":"Nokogiri is vulnerable to XML External Entity (XXE) attack","id":"CVE-2012-6685","kev_date_added":null,"published":"2020-02-19"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.3 Memory Leak via XSLT Transform","id":"CVE-2026-79771","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.9,"headline":"Nokogiri before 1.19.1 Unchecked Return Value canonicalize","id":"CVE-2026-79772","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":6.3,"headline":"Nokogiri: Possible Out-of-Bounds Read in `Nokogiri::XML::NodeSet#[]`","id":"CVE-2026-57235","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["sparklemotion"]},"summary":"An attacker can exploit an XML External Entity vulnerability in Nokogiri on JRuby to read files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2021-41098/"}