# CVE-2021-41098: Improper Restriction of XML External Entity Reference (XXE) in Nokogiri on JRuby

> An attacker can exploit an XML External Entity vulnerability in Nokogiri on JRuby to read files or cause denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2rr5-8q37-2w7h, OESA-2021-1396, openSUSE-SU-2024:11577-1

## What is CVE-2021-41098?

CVE-2021-41098 is a high-severity vulnerability in sparklemotion nokogiri, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nokogiri is a Rubygem providing HTML, XML, SAX, and Reader parsers with XPath and CSS selector support. In Nokogiri v1.12.4 and earlier, on JRuby only, the SAX parser resolves external entities by default. Users of Nokogiri on JRuby who parse untrusted documents using any of these classes are affected: Nokogiri::XML::SAX::Parse, Nokogiri::HTML4::SAX::Parser or its alias Nokogiri::HTML::SAX::Parser, Nokogiri::XML::SAX::PushParser, and Nokogiri::HTML4::SAX::PushParser or its alias Nokogiri::HTML::SAX::PushParser. JRuby users should upgrade to Nokogiri v1.12.5 or later to receive a patch for this issue. There are no workarounds available for v1.12.4 or earlier. CRuby users are not affected.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2021-41098?

2 open source packages ship an affected version, including nokogiri. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.12.5 |
| `nokogiri` | RubyGems | All versions | 1.12.5 |
| `rubygem-nokogiri` | openSUSE:Tumbleweed | All versions | 1.12.5-1.1 |

Products: Nokogiri Nokogiri.

## How do I fix CVE-2021-41098?

Upgrade nokogiri to 1.12.5 or later.

## Is CVE-2021-41098 being exploited?

There is no known exploitation of CVE-2021-41098 in the wild and no public exploit code.

## Other vulnerabilities in sparklemotion nokogiri

- [CVE-2026-79770](https://insights.sbomify.com/CVE-2026-79770/): Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer (high 8.7)
- [CVE-2022-23476](https://insights.sbomify.com/CVE-2022-23476/): Unchecked return value from xmlTextReaderExpand in Nokogiri (high 7.5)
- [CVE-2012-6685](https://insights.sbomify.com/CVE-2012-6685/): Nokogiri is vulnerable to XML External Entity (XXE) attack (high 7.5)
- [CVE-2026-79771](https://insights.sbomify.com/CVE-2026-79771/): Nokogiri before 1.19.3 Memory Leak via XSLT Transform (medium 6.9)
- [CVE-2026-79772](https://insights.sbomify.com/CVE-2026-79772/): Nokogiri before 1.19.1 Unchecked Return Value canonicalize (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41098 and fix it if it is affected.

What it is: CVE-2021-41098 is a high-severity vulnerability in sparklemotion nokogiri, published on 27 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41098 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.12.5
- nokogiri (RubyGems): affected all versions; fixed in 1.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41098/ (Markdown: https://insights.sbomify.com/CVE-2021-41098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41098
- OSV: https://osv.dev/vulnerability/CVE-2021-41098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41098/
Summaries are generated and may contain mistakes; the official description above is the record.
