# CVE-2021-41104: web_server allows OTA update without checking user defined basic auth username & password

> Attackers can perform unauthorized OTA updates on ESPHome devices with web_server enabled, bypassing configured HTTP basic authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-48mj-p7x2-5jfm, PYSEC-2021-351

## What is CVE-2021-41104?

CVE-2021-41104 is a high-severity authentication bypass vulnerability in esphome, published on 28 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ESPHome is a system to control the ESP8266/ESP32. Anyone with web_server enabled and HTTP basic auth configured on version 2021.9.1 or older is vulnerable to an issue in which `web_server` allows over-the-air (OTA) updates without checking user defined basic auth username & password. This issue is patched in version 2021.9.2. As a workaround, one may disable or remove `web_server`.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2021-41104?

3 open source packages ship an affected version, including esphome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `esphome` | PyPI | All versions | 2021.9.2 |
| `esphome` | PyPI | All versions | 2021.9.2 |
| `esphome` | PyPI | All versions | 2021.9.2 |

Products: Esphome Esphome Firmware.

## How do I fix CVE-2021-41104?

Upgrade esphome to 2021.9.2 or later.

## Is CVE-2021-41104 being exploited?

There is no known exploitation of CVE-2021-41104 in the wild and no public exploit code.

## Other vulnerabilities in esphome

- [CVE-2025-57808](https://insights.sbomify.com/CVE-2025-57808/): ESP-IDF web_server basic auth bypass using empty or incomplete Authorization header (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41104 and fix it if it is affected.

What it is: CVE-2021-41104 is a high-severity authentication bypass vulnerability in esphome, published on 28 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41104 in the wild and no public exploit code.

Affected packages and fixed versions:
- esphome (PyPI): affected all versions; fixed in 2021.9.2
- esphome (PyPI): affected all versions; fixed in 2021.9.2
- esphome (PyPI): affected all versions; fixed in 2021.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41104/ (Markdown: https://insights.sbomify.com/CVE-2021-41104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41104
- OSV: https://osv.dev/vulnerability/CVE-2021-41104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41104/
Summaries are generated and may contain mistakes; the official description above is the record.
