# CVE-2021-41114: HTTP Host Header Injection in Request Handling in Typo3

> Attackers can spoof the HTTP Host header to manipulate generated URLs, bypassing security controls in TYPO3 CMS.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-typo3-2021-41114, GHSA-m2jh-fxw4-gphm

## What is CVE-2021-41114?

CVE-2021-41114 is a medium-severity vulnerability in Typo3 Typo3, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that TYPO3 CMS is susceptible to host spoofing due to improper validation of the HTTP Host header. TYPO3 uses the HTTP Host header, for example, to generate absolute URLs during the frontend rendering process. Since the host header itself is provided by the client, it can be forged to any value, even in a name-based virtual hosts environment. This vulnerability is the same as described in TYPO3-CORE-SA-2014-001 (CVE-2014-3941). A regression, introduced during TYPO3 v11 development, led to this situation. The already existing setting $GLOBALS['TYPO3_CONF_VARS']['SYS']['trustedHostsPattern'] (used as an effective mitigation strategy in previous TYPO3 versions) was not evaluated anymore, and reintroduced the vulnerability.

Weakness: CWE-644 (Improper Neutralization of HTTP Headers for Scripting Syntax), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-41114?

5 open source packages ship an affected version, including typo3/cms, typo3 and typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.0 |
| `typo3/cms` | Packagist | From 11.0.0 | 11.5.0 |
| `typo3` | Bitnami | From 11.0.0 | 11.5.0 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.0 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.0 |

Products: Typo3 Typo3.

## How do I fix CVE-2021-41114?

Upgrade typo3/cms to 11.5.0 or later.

## Is CVE-2021-41114 being exploited?

There is no known exploitation of CVE-2021-41114 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41114 and fix it if it is affected.

What it is: CVE-2021-41114 is a medium-severity vulnerability in Typo3 Typo3, published on 5 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41114 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.0
- typo3/cms (Packagist): affected from 11.0.0; fixed in 11.5.0
- typo3 (Bitnami): affected from 11.0.0; fixed in 11.5.0
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.0
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41114/ (Markdown: https://insights.sbomify.com/CVE-2021-41114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41114
- OSV: https://osv.dev/vulnerability/CVE-2021-41114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41114/
Summaries are generated and may contain mistakes; the official description above is the record.
