{"answers":{"affected":"3 open source packages ship an affected version, including vyper. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41121 in the wild and no public exploit code.","fix":"Upgrade vyper to 0.3.0 or later.","what":"CVE-2021-41121 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41121 and fix it if it is affected.\n\nWhat it is: CVE-2021-41121 is a high-severity memory corruption vulnerability in vyperlang vyper, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41121 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vyper (PyPI): affected all versions; fixed in 0.3.0\n- vyper (PyPI): affected all versions; fixed in 0.3.0\n- vyper (PyPI): affected all versions; fixed in 0.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41121/ (Markdown: https://insights.sbomify.com/CVE-2021-41121/index.md)","id":"CVE-2021-41121","markdown":"https://insights.sbomify.com/CVE-2021-41121/index.md","name":"CVE-2021-41121","record":{"aliases":["GHSA-xv8x-pr4h-73jv","PYSEC-2021-365"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vyper smart contract compiler","requires_auth":"low_privilege","summary":"A memory corruption flaw in the Vyper compiler allows attackers to potentially execute arbitrary code via crafted smart contracts.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vyper","vendor":"vyperlang"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Vyper","id":"CVE-2021-41121","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Bounds check missing for decimal args in Vyper","id":"CVE-2021-41122"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":null,"source":"GHSA-xv8x-pr4h-73jv"},{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"GHSA-xv8x-pr4h-73jv"},{"ecosystem":"PyPI","fixed":["0.3.0"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"PYSEC-2021-365"}],"prev":{"headline":"Unauthorized access to Credit card form in sylius/paypal-plugin","id":"CVE-2021-41120"},"products":["vyper"],"published":"2021-10-06","related":[{"cvss_score":9.8,"headline":"Vyper array negative index vulnerability","id":"CVE-2024-24563","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":9.8,"headline":"Vyper bounds check on built-in `slice()` function can be overflowed","id":"CVE-2024-24561","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":9.1,"headline":"Vyper incorrectly allocated named re-entrancy locks","id":"CVE-2023-39363","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":8.8,"headline":"Integer bounds error in Vyper","id":"CVE-2022-24845","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":8.2,"headline":"Multiple evaluation of contract address in call in vyper","id":"CVE-2022-29255","kev_date_added":null,"published":"2022-06-06"},{"cvss_score":8.1,"headline":"Vyper vulnerable to memory corruption in certain builtins utilizing `msize`","id":"CVE-2023-42443","kev_date_added":null,"published":"2023-09-18"},{"cvss_score":7.5,"headline":"Vyper has incorrect storage layout for contracts containing large arrays","id":"CVE-2023-46247","kev_date_added":null,"published":"2023-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["vyperlang"]},"summary":"A memory corruption flaw in the Vyper compiler allows attackers to potentially execute arbitrary code via crafted smart contracts.","url":"https://insights.sbomify.com/CVE-2021-41121/"}