# CVE-2021-41127: Maliciously Crafted Model Archive Can Lead To Arbitrary File Write in rasa


- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4365-fhm5-qcrx, PYSEC-2021-381

## What is CVE-2021-41127?

CVE-2021-41127 is a high-severity vulnerability in RasaHQ rasa, published on 21 Oct 2021. 

### Official description

Rasa is an open source machine learning framework to automate text-and voice-based conversations. In affected versions a vulnerability exists in the functionality that loads a trained model `tar.gz` file which allows a malicious actor to craft a `model.tar.gz` file which can overwrite or replace bot files in the bot directory. The vulnerability is fixed in Rasa 2.8.10. For users unable to update ensure that users do not upload untrusted model files, and restrict CLI or API endpoint access where a malicious actor could target a deployed Rasa instance.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-41127?

3 open source packages ship an affected version, including rasa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rasa` | PyPI | All versions | 2.8.10 |
| `rasa` | PyPI | All versions | 2.8.10 |
| `rasa` | PyPI | All versions | 2.8.10 |

Products: Rasa Rasa.

## How do I fix CVE-2021-41127?

Upgrade rasa to 2.8.10 or later.

## Is CVE-2021-41127 being exploited?

There is no known exploitation of CVE-2021-41127 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41127 and fix it if it is affected.

What it is: CVE-2021-41127 is a high-severity vulnerability in RasaHQ rasa, published on 21 Oct 2021. 
Exploitation: There is no known exploitation of CVE-2021-41127 in the wild and no public exploit code.

Affected packages and fixed versions:
- rasa (PyPI): affected all versions; fixed in 2.8.10
- rasa (PyPI): affected all versions; fixed in 2.8.10
- rasa (PyPI): affected all versions; fixed in 2.8.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41127/ (Markdown: https://insights.sbomify.com/CVE-2021-41127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41127
- OSV: https://osv.dev/vulnerability/CVE-2021-41127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41127/
Summaries are generated and may contain mistakes; the official description above is the record.
