{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41130 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-41130 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-41130 is a medium-severity authentication bypass vulnerability in cloudendpoints esp, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41130 and fix it if it is affected.\n\nWhat it is: CVE-2021-41130 is a medium-severity authentication bypass vulnerability in cloudendpoints esp, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41130 in the wild and no public exploit code.\n\nAffected product: cloudendpoints esp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41130/ (Markdown: https://insights.sbomify.com/CVE-2021-41130/index.md)","id":"CVE-2021-41130","markdown":"https://insights.sbomify.com/CVE-2021-41130/index.md","name":"CVE-2021-41130","record":{"aliases":["GHSA-43wx-8qmj-9r9q"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Extensible Service Proxy","requires_auth":"low_privilege","summary":"Attackers can spoof user identity headers to bypass authorization in Extensible Service Proxy when JWT authentication is configured.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"extensible_service_proxy","vendor":"google"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"Extensible Service Proxy, a.k.a. ESP is a proxy which enables API management capabilities for JSON/REST or gRPC API services. ESPv1 can be configured to authenticate a JWT token. Its verified JWT claim is passed to the application by HTTP header \"X-Endpoint-API-UserInfo\", the application can use it to do authorization. But if there are two \"X-Endpoint-API-UserInfo\" headers from the client, ESPv1 only replaces the first one, the 2nd one will be passed to the application. An attacker can send two \"X-Endpoint-API-UserInfo\" headers, the second one with a fake JWT claim. Application may use the fake JWT claim to do the authorization. This impacts following ESPv1 usages: 1) Users have configured ESPv1 to do JWT authentication with Google ID Token as described in the referenced google endpoint document. 2) Users backend application is using the info in the \"X-Endpoint-API-UserInfo\" header to do the authorization. It has been fixed by v1.58.0. You need to patch it in the following ways: * If your docker image is using tag \":1\", needs to re-start the container to pick up the new version. The tag \":1\" will automatically point to the latest version. * If your docker image tag pings to a specific minor version, e.g. \":1.57\". You need to update it to \":1.58\" and re-start the container. There are no workaround for this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"X-Endpoint-API-UserInfo can be spoofed in cloudendpoints Extensible Service Proxy","id":"CVE-2021-41130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Client metadata path-traversal in python-tuf","id":"CVE-2021-41131"},"packages":[],"prev":{"headline":"Authentication bypass in Pterodactyl","id":"CVE-2021-41129"},"products":["esp"],"published":"2021-10-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["cloudendpoints"]},"summary":"Attackers can spoof user identity headers to bypass authorization in Extensible Service Proxy when JWT authentication is configured.","url":"https://insights.sbomify.com/CVE-2021-41130/"}