# CVE-2021-41130: X-Endpoint-API-UserInfo can be spoofed in cloudendpoints Extensible Service Proxy

> Attackers can spoof user identity headers to bypass authorization in Extensible Service Proxy when JWT authentication is configured.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-43wx-8qmj-9r9q

## What is CVE-2021-41130?

CVE-2021-41130 is a medium-severity authentication bypass vulnerability in cloudendpoints esp, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Extensible Service Proxy, a.k.a. ESP is a proxy which enables API management capabilities for JSON/REST or gRPC API services. ESPv1 can be configured to authenticate a JWT token. Its verified JWT claim is passed to the application by HTTP header "X-Endpoint-API-UserInfo", the application can use it to do authorization. But if there are two "X-Endpoint-API-UserInfo" headers from the client, ESPv1 only replaces the first one, the 2nd one will be passed to the application. An attacker can send two "X-Endpoint-API-UserInfo" headers, the second one with a fake JWT claim. Application may use the fake JWT claim to do the authorization. This impacts following ESPv1 usages: 1) Users have configured ESPv1 to do JWT authentication with Google ID Token as described in the referenced google endpoint document. 2) Users backend application is using the info in the "X-Endpoint-API-UserInfo" header to do the authorization. It has been fixed by v1.58.0. You need to patch it in the following ways: * If your docker image is using tag ":1", needs to re-start the container to pick up the new version. The tag ":1" will automatically point to the latest version. * If your docker image tag pings to a specific minor version, e.g. ":1.57". You need to update it to ":1.58" and re-start the container. There are no workaround for this issue.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2021-41130?

It affects 1 product.


Products: Google Extensible Service Proxy.

## How do I fix CVE-2021-41130?

No fix has been published for CVE-2021-41130 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-41130 being exploited?

There is no known exploitation of CVE-2021-41130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41130 and fix it if it is affected.

What it is: CVE-2021-41130 is a medium-severity authentication bypass vulnerability in cloudendpoints esp, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41130 in the wild and no public exploit code.

Affected product: cloudendpoints esp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41130/ (Markdown: https://insights.sbomify.com/CVE-2021-41130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41130
- OSV: https://osv.dev/vulnerability/CVE-2021-41130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41130/
Summaries are generated and may contain mistakes; the official description above is the record.
