# CVE-2021-41131: Client metadata path-traversal in python-tuf

> Attackers can overwrite arbitrary JSON files on client systems via path traversal in python-tuf if arbitrary rolename selection is allowed.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2021
- **Updated:** 18 Nov 2024
- **Also known as:** GHSA-wjw6-2cqr-j4qr, PYSEC-2021-376

## What is CVE-2021-41131?

CVE-2021-41131 is a high-severity path traversal vulnerability in theupdateframework python-tuf, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-tuf is a Python reference implementation of The Update Framework (TUF). In both clients (`tuf/client` and `tuf/ngclient`), there is a path traversal vulnerability that in the worst case can overwrite files ending in `.json` anywhere on the client system on a call to `get_one_valid_targetinfo()`. It occurs because the rolename is used to form the filename, and may contain path traversal characters (ie `../../name.json`). The impact is mitigated by a few facts: It only affects implementations that allow arbitrary rolename selection for delegated targets metadata, The attack requires the ability to A) insert new metadata for the path-traversing role and B) get the role delegated by an existing targets metadata, The written file content is heavily restricted since it needs to be a valid, signed targets file. The file extension is always .json. A fix is available in version 0.19 or newer. There are no workarounds that do not require code changes. Clients can restrict the allowed character set for rolenames, or they can store metadata in files named in a way that is not vulnerable: neither of these approaches is possible without modifying python-tuf.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-41131?

3 open source packages ship an affected version, including tuf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tuf` | PyPI | All versions | 0.19.0 |
| `tuf` | PyPI | All versions | 0.19.0 |
| `tuf` | PyPI | All versions | 0.19.0 |

Products: Linuxfoundation the Update Framework.

## How do I fix CVE-2021-41131?

Upgrade tuf to 0.19.0 or later.

## Is CVE-2021-41131 being exploited?

There is no known exploitation of CVE-2021-41131 in the wild and no public exploit code.

## Other vulnerabilities in theupdateframework python-tuf

- [CVE-2020-6174](https://insights.sbomify.com/CVE-2020-6174/): Incorrect threshold signature computation in TUF (critical 9.8)
- [CVE-2020-15163](https://insights.sbomify.com/CVE-2020-15163/): Invalid root may become trusted root in The Update Framework (TUF) (high 8.7)
- [CVE-2020-6173](https://insights.sbomify.com/CVE-2020-6173/): Client Denial of Service on TUF (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41131 and fix it if it is affected.

What it is: CVE-2021-41131 is a high-severity path traversal vulnerability in theupdateframework python-tuf, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41131 in the wild and no public exploit code.

Affected packages and fixed versions:
- tuf (PyPI): affected all versions; fixed in 0.19.0
- tuf (PyPI): affected all versions; fixed in 0.19.0
- tuf (PyPI): affected all versions; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41131/ (Markdown: https://insights.sbomify.com/CVE-2021-41131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41131
- OSV: https://osv.dev/vulnerability/CVE-2021-41131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41131/
Summaries are generated and may contain mistakes; the official description above is the record.
