CVE-2021-41136 Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma
Attackers can smuggle HTTP requests via Apache Traffic Server, causing responses to be sent to wrong clients, leading to data leakage.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-41136?
CVE-2021-41136 is a low-severity vulnerability in Debian Debian Linux, published on 12 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.
Weakness: CWE-444
Which versions are affected by CVE-2021-41136?
4 open source packages ship an affected version, including puma. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
puma RubyGems | All versions | 4.3.9 |
puma RubyGems | All versions | 4.3.9 |
puma RubyGems | From 5.0.0 | 5.5.1 |
puma RubyGems | From 5.0.0 | 5.5.1 |
Products include Debian Debian Linux, Puma Puma.
How do I fix CVE-2021-41136?
Upgrade puma to a fixed version for your release line: 4.3.9 or 5.5.1.
Is CVE-2021-41136 being exploited?
There is no known exploitation of CVE-2021-41136 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2021-41136, GHSA-48w2-rm65-62xx, OESA-2023-1981, OESA-2023-1982, OESA-2023-1983.