{"answers":{"affected":"4 open source packages ship an affected version, including puma. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-41136 in the wild and no public exploit code.","fix":"Upgrade puma to a fixed version for your release line: 4.3.9 or 5.5.1.","what":"CVE-2021-41136 is a low-severity vulnerability in Debian Debian Linux, published on 12 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41136 and fix it if it is affected.\n\nWhat it is: CVE-2021-41136 is a low-severity vulnerability in Debian Debian Linux, published on 12 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41136 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puma (RubyGems): affected all versions; fixed in 4.3.9\n- puma (RubyGems): affected all versions; fixed in 4.3.9\n- puma (RubyGems): affected from 5.0.0; fixed in 5.5.1\n- puma (RubyGems): affected from 5.0.0; fixed in 5.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41136/ (Markdown: https://insights.sbomify.com/CVE-2021-41136/index.md)","id":"CVE-2021-41136","markdown":"https://insights.sbomify.com/CVE-2021-41136/index.md","name":"CVE-2021-41136","record":{"aliases":["DEBIAN-CVE-2021-41136","GHSA-48w2-rm65-62xx","OESA-2023-1981","OESA-2023-1982","OESA-2023-1983"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby HTTP server","requires_auth":"low_privilege","summary":"Attackers can smuggle HTTP requests via Apache Traffic Server, causing responses to be sent to wrong clients, leading to data leakage.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"puma","vendor":"puma"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma","id":"CVE-2021-41136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"other","year":"2021"},"n_packages":4,"n_references":4,"next":{"headline":"Bypassing policy restrictions on regular users","id":"CVE-2021-41137"},"packages":[{"ecosystem":"RubyGems","fixed":["4.3.9"],"introduced":["0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-48w2-rm65-62xx"},{"ecosystem":"RubyGems","fixed":["4.3.9"],"introduced":["0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-48w2-rm65-62xx"},{"ecosystem":"RubyGems","fixed":["5.5.1"],"introduced":["5.0.0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-48w2-rm65-62xx"},{"ecosystem":"RubyGems","fixed":["5.5.1"],"introduced":["5.0.0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-48w2-rm65-62xx"}],"prev":{"headline":"Authz Module Non-Determinism","id":"CVE-2021-41135"},"products":["puma"],"published":"2021-10-12","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-05-27","vendors":["puma"]},"summary":"Attackers can smuggle HTTP requests via Apache Traffic Server, causing responses to be sent to wrong clients, leading to data leakage.","url":"https://insights.sbomify.com/CVE-2021-41136/"}