CVE-2021-41143 OpenMage LTS arbitrary file deletion in customer media allows for remote code execution
Admin users with customer media access can delete arbitrary files to achieve remote code execution on OpenMage LTS servers.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-41143?
CVE-2021-41143 is a high-severity path traversal vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Magento admin users with access to the customer media could execute code on the server. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
Which versions are affected by CVE-2021-41143?
4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openmage/magento-lts Packagist | All versions | 19.4.22 |
openmage/magento-lts Packagist | All versions | 19.4.22 |
openmage/magento-lts Packagist | From 20.0.0 | 20.0.19 |
openmage/magento-lts Packagist | From 20.0.0 | 20.0.19 |
Products include Openmage Magento.
How do I fix CVE-2021-41143?
Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2021-41143 being exploited?
There is no known exploitation of CVE-2021-41143 in the wild and no public exploit code.
Other vulnerabilities in OpenMage magento-lts
- CVE-2021-21426 Fixes a bug in Zend Framework's Stream HTTP Wrapper
- CVE-2021-21427 Backport for CVE-2021-21024 Blind SQLi from Magento 2
- CVE-2021-41144 OpenMage LTS authenticated remote code execution through layout update
- CVE-2026-40488 OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution
- CVE-2026-25524 OpenMage LTS's Phar Deserialization leads to Remote Code Execution
Sources
Also known as GHSA-5vpv-xmcj-9q85.