CVE-2021-41144 OpenMage LTS authenticated remote code execution through layout update

High 8.8 Published Updated

Authenticated attackers can execute remote code in OpenMage LTS by bypassing block blacklists via layout updates.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-41144?

CVE-2021-41144 is a high-severity code injection vulnerability in OpenMage magento-lts, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Weakness: CWE-77

Which versions are affected by CVE-2021-41144?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistFrom 20.0.020.0.19
openmage/magento-lts PackagistFrom 20.0.020.0.19

Products include Openmage Magento.

How do I fix CVE-2021-41144?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2021-41144 being exploited?

There is no known exploitation of CVE-2021-41144 in the wild and no public exploit code.

Sources

Also known as GHSA-5j2g-3ph4-rgvm.

Is CVE-2021-41144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free