# CVE-2021-41151: Path Traversal in @backstage/plugin-scaffolder-backend

> Attackers with template creation rights can read sensitive files via path traversal in Scaffolder tasks, exposing data in pull requests.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pvv8-8fx9-h673

## What is CVE-2021-41151?

CVE-2021-41151 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 18 Oct 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Backstage is an open platform for building developer portals. In affected versions A malicious actor could read sensitive files from the environment where Scaffolder Tasks are run. The attack is executed by crafting a custom Scaffolder template with a `github:publish:pull-request` action and a particular source path. When the template is executed the sensitive files would be included in the published pull request. This vulnerability is mitigated by the fact that an attacker would need access to create and register templates in the Backstage catalog, and that the attack is very visible given that the exfiltration happens via a pull request. The vulnerability is patched in the `0.15.9` release of `@backstage/plugin-scaffolder-backend`.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-41151?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | From 0.9.4 | 0.15.9 |
| `@backstage/plugin-scaffolder-backend` | npm | From 0.9.4 | 0.15.9 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2021-41151?

Upgrade @backstage/plugin-scaffolder-backend to 0.15.9 or later.

## Is CVE-2021-41151 being exploited?

There is no known exploitation of CVE-2021-41151 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41151 and fix it if it is affected.

What it is: CVE-2021-41151 is a medium-severity path traversal vulnerability in Linuxfoundation Backstage, published on 18 Oct 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41151 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected from 0.9.4; fixed in 0.15.9
- @backstage/plugin-scaffolder-backend (npm): affected from 0.9.4; fixed in 0.15.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41151/ (Markdown: https://insights.sbomify.com/CVE-2021-41151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41151
- OSV: https://osv.dev/vulnerability/CVE-2021-41151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41151/
Summaries are generated and may contain mistakes; the official description above is the record.
