{"answers":{"affected":"2 open source packages ship an affected version, including evm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41153 in the wild and no public exploit code.","fix":"Upgrade evm to 0.31.0 or later.","what":"CVE-2021-41153 is a high-severity vulnerability in rust-blockchain evm, published on 18 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41153 and fix it if it is affected.\n\nWhat it is: CVE-2021-41153 is a high-severity vulnerability in rust-blockchain evm, published on 18 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41153 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- evm (crates.io): affected all versions; fixed in 0.31.0\n- evm (crates.io): affected all versions; fixed in 0.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41153/ (Markdown: https://insights.sbomify.com/CVE-2021-41153/index.md)","id":"CVE-2021-41153","markdown":"https://insights.sbomify.com/CVE-2021-41153/index.md","name":"CVE-2021-41153","record":{"aliases":["GHSA-pvh2-pj76-4m96"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust EVM library","requires_auth":"none","summary":"Incorrect JUMPI opcode execution order in the evm crate causes consensus divergence on Ethereum mainnet, requiring an immediate library upgrade.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"evm","vendor":"evm_project"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-670","name":"Always-Incorrect Control Flow Implementation"}],"description":"The evm crate is a pure Rust implementation of Ethereum Virtual Machine. In `evm` crate `\u003c 0.31.0`, `JUMPI` opcode's condition is checked after the destination validity check. However, according to Geth and OpenEthereum, the condition check should happen before the destination validity check. This is a **high** severity security advisory if you use `evm` crate for Ethereum mainnet. In this case, you should update your library dependency immediately to on or after `0.31.0`. This is a **low** severity security advisory if you use `evm` crate in Frontier or in a standalone blockchain, because there's no security exploit possible with this advisory. It is **not** recommended to update to on or after `0.31.0` until all the normal chain upgrade preparations have been done. If you use Frontier or other `pallet-evm` based Substrate blockchain, please ensure to update your `spec_version` before updating this. For other blockchains, please make sure to follow a hard-fork process before you update this.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Specification non-compliance in JUMPI","id":"CVE-2021-41153","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"other","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"SQL injection in the \"SVN core\" commits browser","id":"CVE-2021-41154"},"packages":[{"ecosystem":"crates.io","fixed":["0.31.0"],"introduced":["0"],"last_affected":[],"package":"evm","purl":null,"source":"GHSA-pvh2-pj76-4m96"},{"ecosystem":"crates.io","fixed":["0.31.0"],"introduced":["0"],"last_affected":[],"package":"evm","purl":"pkg:cargo/evm","source":"GHSA-pvh2-pj76-4m96"}],"prev":{"headline":"Path Traversal in Folder Component Leading to Local File Inclusion","id":"CVE-2021-41152"},"products":["evm"],"published":"2021-10-18","related":[{"cvss_score":6.5,"headline":"Memory over-allocation in evm crate","id":"CVE-2021-29511","kev_date_added":null,"published":"2021-05-12"},{"cvss_score":5.9,"headline":"Erroneous handling of `record_external_operation` error return","id":"CVE-2024-21629","kev_date_added":null,"published":"2024-01-02"},{"cvss_score":5.9,"headline":"evm has incorrect is_static parameter for custom stateful precompiles","id":"CVE-2022-39354","kev_date_added":null,"published":"2022-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["rust-blockchain"]},"summary":"Incorrect JUMPI opcode execution order in the evm crate causes consensus divergence on Ethereum mainnet, requiring an immediate library upgrade.","url":"https://insights.sbomify.com/CVE-2021-41153/"}