# CVE-2021-41163: RCE via malicious SNS subscription payload

> Attackers can achieve remote code execution in Discourse by sending maliciously crafted SNS subscription payloads due to insufficient validation.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-discourse-2021-41163, GHSA-jcjx-pvpc-qgwq

## What is CVE-2021-41163?

CVE-2021-41163 is a critical code injection vulnerability in Discourse Discourse, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. In affected versions maliciously crafted requests could lead to remote code execution. This resulted from a lack of validation in subscribe_url values. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. To workaround the issue without updating, requests with a path starting /webhooks/aws path could be blocked at an upstream proxy.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-41163?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.7.9 |

Products: Discourse Discourse.

## How do I fix CVE-2021-41163?

Upgrade discourse to 2.7.9 or later.

## Is CVE-2021-41163 being exploited?

There is no known exploitation of CVE-2021-41163 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)
- [CVE-2025-48053](https://insights.sbomify.com/CVE-2025-48053/): Discourse vulnerable to DoS via large URL payload in PM to a bot (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41163 and fix it if it is affected.

What it is: CVE-2021-41163 is a critical code injection vulnerability in Discourse Discourse, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41163 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.7.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41163/ (Markdown: https://insights.sbomify.com/CVE-2021-41163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41163
- OSV: https://osv.dev/vulnerability/CVE-2021-41163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41163/
Summaries are generated and may contain mistakes; the official description above is the record.
