CVE-2021-41164 Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML

High 8.2 Published Updated

An attacker can execute JavaScript code by injecting malformed HTML that bypasses sanitization in CKEditor 4.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-41164?

CVE-2021-41164 is a high-severity cross-site scripting vulnerability in Drupal Drupal, published on 17 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Weakness: CWE-79

Which versions are affected by CVE-2021-41164?

3 open source packages ship an affected version, including drupal and ckeditor4. It affects 10 products.

PackageAffectedFixed in
drupal BitnamiFrom 8.9.08.9.20, 9.1.14, 9.2.9
ckeditor4 npmAll versions4.17.0
ckeditor4 npmAll versions4.17.0

Products include Ckeditor Ckeditor, Drupal Drupal, Fedoraproject Fedora, Oracle Agile Product Lifecycle Management, Oracle Application Express, Oracle Banking Apis and 4 more.

How do I fix CVE-2021-41164?

Upgrade drupal to a fixed version for your release line: 8.9.20, 9.1.14 or 9.2.9.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-41164 being exploited?

There is no known exploitation of CVE-2021-41164 in the wild and no public exploit code.

All Drupal Drupal vulnerabilities

Sources

Also known as BIT-drupal-2021-41164, DEBIAN-CVE-2021-41164, GHSA-pvmx-g8h5-cprj, UBUNTU-CVE-2021-41164.

Is CVE-2021-41164 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free