# CVE-2021-41165: HTML comments vulnerability allowing to execute JavaScript code

> An attacker can execute JavaScript code by injecting malformed HTML comments that bypass content sanitization in CKEditor 4.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-drupal-2021-41165, DEBIAN-CVE-2021-41165, GHSA-7h26-63m7-qhf2, UBUNTU-CVE-2021-41165

## What is CVE-2021-41165?

CVE-2021-41165 is a high-severity cross-site scripting vulnerability in Drupal Drupal, published on 17 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-41165?

5 open source packages ship an affected version, including drupal, ckeditor/ckeditor and ckeditor4. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal` | Bitnami | From 8.9.0 | 8.9.20, 9.1.14, 9.2.9 |
| `ckeditor/ckeditor` | Packagist | All versions | 4.17.0 |
| `ckeditor/ckeditor` | Packagist | All versions | 4.17.0 |
| `ckeditor4` | npm | All versions | 4.17.0 |
| `ckeditor4` | npm | All versions | 4.17.0 |

Products: Ckeditor Ckeditor, Drupal Drupal, Oracle Agile Product Lifecycle Management, Oracle Application Express, Oracle Banking Apis, Oracle Banking Digital Experience, Oracle Commerce Guided Search, Oracle Peoplesoft Enterprise Peopletools, Oracle Webcenter Portal.

## How do I fix CVE-2021-41165?

Upgrade drupal to a fixed version for your release line: 8.9.20, 9.1.14 or 9.2.9.

## Is CVE-2021-41165 being exploited?

There is no known exploitation of CVE-2021-41165 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)
- [CVE-2021-37695](https://insights.sbomify.com/CVE-2021-37695/): Execution of JavaScript code using malformed HTML in ckeditor (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41165 and fix it if it is affected.

What it is: CVE-2021-41165 is a high-severity cross-site scripting vulnerability in Drupal Drupal, published on 17 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41165 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal (Bitnami): affected from 8.9.0; fixed in 8.9.20, 9.1.14, 9.2.9
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.17.0
- ckeditor/ckeditor (Packagist): affected all versions; fixed in 4.17.0
- ckeditor4 (npm): affected all versions; fixed in 4.17.0
- ckeditor4 (npm): affected all versions; fixed in 4.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41165/ (Markdown: https://insights.sbomify.com/CVE-2021-41165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41165
- OSV: https://osv.dev/vulnerability/CVE-2021-41165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41165/
Summaries are generated and may contain mistakes; the official description above is the record.
