# CVE-2021-41167: Unlimited requests in modern-async

> The modern-async library fails to limit concurrency in forEachSeries and forEachLimit, potentially causing resource exhaustion and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3pcq-34w5-p4g2

## What is CVE-2021-41167?

CVE-2021-41167 is a high-severity denial of service vulnerability in nicolas-van modern-async, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

modern-async is an open source JavaScript tooling library for asynchronous operations using async/await and promises. In affected versions a bug affecting two of the functions in this library: forEachSeries and forEachLimit. They should limit the concurrency of some actions but, in practice, they don't. Any code calling these functions will be written thinking they would limit the concurrency but they won't. This could lead to potential security issues in other projects. The problem has been patched in 1.0.4. There is no workaround.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-41167?

2 open source packages ship an affected version, including modern-async. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modern-async` | npm | All versions | 1.0.4 |
| `modern-async` | npm | All versions | 1.0.4 |

Products: Modern-Async Project Modern-Async.

## How do I fix CVE-2021-41167?

Upgrade modern-async to 1.0.4 or later.

## Is CVE-2021-41167 being exploited?

There is no known exploitation of CVE-2021-41167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41167 and fix it if it is affected.

What it is: CVE-2021-41167 is a high-severity denial of service vulnerability in nicolas-van modern-async, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41167 in the wild and no public exploit code.

Affected packages and fixed versions:
- modern-async (npm): affected all versions; fixed in 1.0.4
- modern-async (npm): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41167/ (Markdown: https://insights.sbomify.com/CVE-2021-41167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41167
- OSV: https://osv.dev/vulnerability/CVE-2021-41167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41167/
Summaries are generated and may contain mistakes; the official description above is the record.
