# CVE-2021-41172: Self-XSS in AS_Redis

> Self-XSS in the AS_Redis plugin for AntSword allows attackers to execute arbitrary code via insufficient input validation in the plugin configuration.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 26 Oct 2021
- **Updated:** 4 Aug 2024

## What is CVE-2021-41172?

CVE-2021-41172 is a medium-severity cross-site scripting vulnerability in Medicean AS_Redis, published on 26 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

AS_Redis is an AntSword plugin for Redis. The Redis Manage plugin for AntSword prior to version 0.5 is vulnerable to Self-XSS due to due to insufficient input validation and sanitization via redis server configuration. Self-XSS in the plugin configuration leads to code execution. This issue is patched in version 0.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-41172?

It affects 1 product.


Products: Antsword Redis Project Antsword Redis.

## How do I fix CVE-2021-41172?

No fix has been published for CVE-2021-41172 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-41172 being exploited?

There is no known exploitation of CVE-2021-41172 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41172 and fix it if it is affected.

What it is: CVE-2021-41172 is a medium-severity cross-site scripting vulnerability in Medicean AS_Redis, published on 26 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41172 in the wild and no public exploit code.

Affected product: Medicean AS_Redis. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41172/ (Markdown: https://insights.sbomify.com/CVE-2021-41172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41172
- OSV: https://osv.dev/vulnerability/CVE-2021-41172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41172/
Summaries are generated and may contain mistakes; the official description above is the record.
