# CVE-2021-41174: XSS vulnerability allowing arbitrary JavaScript execution

> Attackers can execute arbitrary JavaScript in victims' browsers via crafted URLs, potentially leading to account takeover.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-grafana-2021-41174, GHSA-3j9m-hcv9-rpj8, UBUNTU-CVE-2021-41174

## What is CVE-2021-41174?

CVE-2021-41174 is a medium-severity cross-site scripting vulnerability in Grafana Grafana, published on 3 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Grafana is an open-source platform for monitoring and observability. In affected versions if an attacker is able to convince a victim to visit a URL referencing a vulnerable page, arbitrary JavaScript content may be executed within the context of the victim's browser. The user visiting the malicious link must be unauthenticated and the link must be for a page that contains the login button in the menu bar. The url has to be crafted to exploit AngularJS rendering and contain the interpolation binding for AngularJS expressions. AngularJS uses double curly braces for interpolation binding: {{ }} ex: {{constructor.constructor(‘alert(1)’)()}}. When the user follows the link and the page renders, the login button will contain the original link with a query parameter to force a redirect to the login page. The URL is not validated and the AngularJS rendering engine will execute the JavaScript expression contained in the URL. Users are advised to upgrade as soon as possible. If for some reason you cannot upgrade, you can use a reverse proxy or similar to block access to block the literal string {{ in the path.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-41174?

3 open source packages ship an affected version, including @grafana/data and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@grafana/data` | npm | From 8.0.0 | 8.2.3 |
| `@grafana/data` | npm | From 8.0.0 | 8.2.3 |
| `grafana` | Bitnami | From 8.0.0 | 8.2.3 |

Products: Grafana Grafana.

## How do I fix CVE-2021-41174?

Upgrade @grafana/data to 8.2.3 or later.

## Is CVE-2021-41174 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-41174 exists.

Public exploit code:

- Grafana 8.0.0 <= v.8.2.2 - Angularjs Rendering Cross-Site Scripting (nuclei): http/cves/2021/CVE-2021-41174.yaml

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41174 and fix it if it is affected.

What it is: CVE-2021-41174 is a medium-severity cross-site scripting vulnerability in Grafana Grafana, published on 3 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-41174 exists.

Affected packages and fixed versions:
- @grafana/data (npm): affected from 8.0.0; fixed in 8.2.3
- @grafana/data (npm): affected from 8.0.0; fixed in 8.2.3
- grafana (Bitnami): affected from 8.0.0; fixed in 8.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41174/ (Markdown: https://insights.sbomify.com/CVE-2021-41174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41174
- OSV: https://osv.dev/vulnerability/CVE-2021-41174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41174/
Summaries are generated and may contain mistakes; the official description above is the record.
