# CVE-2021-41177: Rate-limits not working on instances without configured memory cache backend

> Attackers can bypass rate limits on two-factor authentication codes in Nextcloud instances lacking a configured memory cache backend.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fj39-4qx4-m3f2

## What is CVE-2021-41177?

CVE-2021-41177 is a high-severity vulnerability in Nextcloud Nextcloud Server, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.

Weakness: CWE-799 (Improper Control of Interaction Frequency)

## Which versions are affected by CVE-2021-41177?

It affects 1 product.


Products: Nextcloud Nextcloud Server.

## How do I fix CVE-2021-41177?

Upgrade to a fixed version.

## Is CVE-2021-41177 being exploited?

There is no known exploitation of CVE-2021-41177 in the wild and no public exploit code.

## Other vulnerabilities in Nextcloud Nextcloud Server

- [CVE-2021-32802](https://insights.sbomify.com/CVE-2021-32802/): Preview generation used third-party library not suited for user-generated content in Nextcloud server (critical 9.3)
- [CVE-2023-26482](https://insights.sbomify.com/CVE-2023-26482/): Scope of workflow operations is not validated in nextcloud server (critical 9.1)
- [CVE-2018-3775](https://insights.sbomify.com/CVE-2018-3775/): Auth bypass in Nextcloud Server (high 8.8)
- [CVE-2023-35172](https://insights.sbomify.com/CVE-2023-35172/): Nextcloud Server password reset endpoint is not brute force protected (high 8.7)
- [CVE-2023-32320](https://insights.sbomify.com/CVE-2023-32320/): Nextcloud Server's brute force protection allows someone to send more requests than intended (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41177 and fix it if it is affected.

What it is: CVE-2021-41177 is a high-severity vulnerability in Nextcloud Nextcloud Server, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41177 in the wild and no public exploit code.

Affected product: Nextcloud Nextcloud Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41177/ (Markdown: https://insights.sbomify.com/CVE-2021-41177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41177
- OSV: https://osv.dev/vulnerability/CVE-2021-41177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41177/
Summaries are generated and may contain mistakes; the official description above is the record.
