{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41178 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-41178 is a high-severity path traversal vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41178 and fix it if it is affected.\n\nWhat it is: CVE-2021-41178 is a high-severity path traversal vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41178 in the wild and no public exploit code.\n\nAffected product: nextcloud security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41178/ (Markdown: https://insights.sbomify.com/CVE-2021-41178/index.md)","id":"CVE-2021-41178","markdown":"https://insights.sbomify.com/CVE-2021-41178/index.md","name":"CVE-2021-41178","record":{"aliases":["GHSA-jp9c-vpr3-m5rf"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Nextcloud Server","requires_auth":"low_privilege","summary":"Attackers can download arbitrary SVG files from the host system, potentially enabling phishing attacks via malicious SVGs, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"server","vendor":"nextcloud"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, a file traversal vulnerability makes an attacker able to download arbitrary SVG images from the host system, including user provided files. This could also be leveraged into a XSS/phishing attack, an attacker could upload a malicious SVG file that mimics the Nextcloud login form and send a specially crafted link to victims. The XSS risk here is mitigated due to the fact that Nextcloud employs a strict Content-Security-Policy disallowing execution of arbitrary JavaScript. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"File Traversal affecting SVG files on Nextcloud Server","id":"CVE-2021-41178","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Two-Factor Authentication not enforced for pages marked as public","id":"CVE-2021-41179"},"packages":[],"prev":{"headline":"Rate-limits not working on instances without configured memory cache backend","id":"CVE-2021-41177"},"products":["security-advisories"],"published":"2021-10-25","related":[{"cvss_score":6.5,"headline":"Two-Factor Authentication not enforced for pages marked as public","id":"CVE-2021-41179","kev_date_added":null,"published":"2021-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["nextcloud"]},"summary":"Attackers can download arbitrary SVG files from the host system, potentially enabling phishing attacks via malicious SVGs, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2021-41178/"}