# CVE-2021-41178: File Traversal affecting SVG files on Nextcloud Server

> Attackers can download arbitrary SVG files from the host system, potentially enabling phishing attacks via malicious SVGs, requiring an upgrade to fix.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jp9c-vpr3-m5rf

## What is CVE-2021-41178?

CVE-2021-41178 is a high-severity path traversal vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, a file traversal vulnerability makes an attacker able to download arbitrary SVG images from the host system, including user provided files. This could also be leveraged into a XSS/phishing attack, an attacker could upload a malicious SVG file that mimics the Nextcloud login form and send a specially crafted link to victims. The XSS risk here is mitigated due to the fact that Nextcloud employs a strict Content-Security-Policy disallowing execution of arbitrary JavaScript. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2021-41178?

It affects 1 product.


Products: Nextcloud Server.

## How do I fix CVE-2021-41178?

Upgrade to a fixed version.

## Is CVE-2021-41178 being exploited?

There is no known exploitation of CVE-2021-41178 in the wild and no public exploit code.

## Other vulnerabilities in nextcloud security-advisories

- [CVE-2021-41179](https://insights.sbomify.com/CVE-2021-41179/): Two-Factor Authentication not enforced for pages marked as public (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41178 and fix it if it is affected.

What it is: CVE-2021-41178 is a high-severity path traversal vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41178 in the wild and no public exploit code.

Affected product: nextcloud security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41178/ (Markdown: https://insights.sbomify.com/CVE-2021-41178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41178
- OSV: https://osv.dev/vulnerability/CVE-2021-41178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41178/
Summaries are generated and may contain mistakes; the official description above is the record.
