{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41188 in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.7.6 or later.","what":"CVE-2021-41188 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 26 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41188 and fix it if it is affected.\n\nWhat it is: CVE-2021-41188 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 26 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected all versions; fixed in 5.7.6\n- shopware/shopware (Packagist): affected all versions; fixed in 5.7.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41188/ (Markdown: https://insights.sbomify.com/CVE-2021-41188/index.md)","id":"CVE-2021-41188","markdown":"https://insights.sbomify.com/CVE-2021-41188/index.md","name":"CVE-2021-41188","record":{"aliases":["GHSA-4p3x-8qw9-24w9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious scripts into the Shopware administration interface, potentially compromising admin accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"shopware","vendor":"shopware"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authenticated Stored XSS in Administration","id":"CVE-2021-41188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"shopware:shopware","products":["shopware:shopware"],"type":"xss","year":"2021"},"n_packages":2,"n_references":5,"next":{"headline":"Communities and collections administrators can escalate their privilege up to system administrator","id":"CVE-2021-41189"},"packages":[{"ecosystem":"Packagist","fixed":["5.7.6"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-4p3x-8qw9-24w9"},{"ecosystem":"Packagist","fixed":["5.7.6"],"introduced":["0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-4p3x-8qw9-24w9"}],"prev":{"headline":"SQL Injection in DHIS2 Tracker API","id":"CVE-2021-41187"},"products":["shopware"],"published":"2021-10-26","related":[{"cvss_score":10,"headline":"Improper Control of Generation of Code in Twig rendered views in shopware","id":"CVE-2023-22731","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Shopware RCE Vulnerability","id":"CVE-2016-3109","kev_date_added":null,"published":"2017-04-21"},{"cvss_score":9.3,"headline":"Blind SQL-injection in DAL aggregations in Shopware","id":"CVE-2024-22406","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":9.1,"headline":"Leak of information via Store-API","id":"CVE-2021-32711","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.9,"headline":"Shopware unauthenticated data extraction possible through store-api.order endpoint","id":"CVE-2026-31887","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.9,"headline":"Shopware has a potential take over of app credentials","id":"CVE-2026-31889","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.8,"headline":"Improper Control of Generation of Code in Twig Rendered Views in Shopware","id":"CVE-2023-2017","kev_date_added":null,"published":"2023-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["shopware"]},"summary":"Authenticated attackers can inject malicious scripts into the Shopware administration interface, potentially compromising admin accounts.","url":"https://insights.sbomify.com/CVE-2021-41188/"}