{"answers":{"affected":"2 open source packages ship an affected version, including org.dspace:dspace-api. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41189 in the wild and no public exploit code.","fix":"Upgrade org.dspace:dspace-api to 7.1 or later.","what":"CVE-2021-41189 is a high-severity vulnerability in DSpace, published on 29 Oct 2021."},"fix_prompt":"Check this codebase for CVE-2021-41189 and fix it if it is affected.\n\nWhat it is: CVE-2021-41189 is a high-severity vulnerability in DSpace, published on 29 Oct 2021. \nExploitation: There is no known exploitation of CVE-2021-41189 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.dspace:dspace-api (Maven): affected from 7.0; fixed in 7.1\n- org.dspace:dspace-api (Maven): affected from 7.0; fixed in 7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41189/ (Markdown: https://insights.sbomify.com/CVE-2021-41189/index.md)","id":"CVE-2021-41189","markdown":"https://insights.sbomify.com/CVE-2021-41189/index.md","name":"CVE-2021-41189","record":{"aliases":["GHSA-cf2j-vf36-c6w8"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"dspace","vendor":"duraspace"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"DSpace is an open source turnkey repository application. In version 7.0, any community or collection administrator can escalate their permission up to become system administrator. This vulnerability only exists in 7.0 and does not impact 6.x or below. This issue is patched in version 7.1. As a workaround, users of 7.0 may temporarily disable the ability for community or collection administrators to manage permissions or workflows settings.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Communities and collections administrators can escalate their privilege up to system administrator","id":"CVE-2021-41189","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":null,"year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Clarify Content-Type handling in OCI spec","id":"CVE-2021-41190"},"packages":[{"ecosystem":"Maven","fixed":["7.1"],"introduced":["7.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":null,"source":"GHSA-cf2j-vf36-c6w8"},{"ecosystem":"Maven","fixed":["7.1"],"introduced":["7.0"],"last_affected":[],"package":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","source":"GHSA-cf2j-vf36-c6w8"}],"prev":{"headline":"Authenticated Stored XSS in Administration","id":"CVE-2021-41188"},"products":["DSpace"],"published":"2021-10-29","related":[{"cvss_score":8.2,"headline":"Path traversal vulnerabilities in DSpace JSPUI submission upload","id":"CVE-2022-31194","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.5,"headline":"High severity vulnerability that affects org.dspace:dspace-xmlui","id":"CVE-2016-10726","kev_date_added":null,"published":"2018-07-10"},{"cvss_score":7.2,"headline":"Path traversal vulnerability in Simple Archive Format package import in DSpace","id":"CVE-2022-31195","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.1,"headline":"Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools","id":"CVE-2022-31191","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.1,"headline":"Cross Site Scripting possible in DSpace JSPUI \"Request a Copy\" feature","id":"CVE-2022-31192","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.1,"headline":"URL Redirection to Untrusted Site in Dspace JSPUI","id":"CVE-2022-31193","kev_date_added":null,"published":"2022-08-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["DSpace"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-41189/"}