# CVE-2021-41189: Communities and collections administrators can escalate their privilege up to system administrator


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cf2j-vf36-c6w8

## What is CVE-2021-41189?

CVE-2021-41189 is a high-severity vulnerability in DSpace, published on 29 Oct 2021. 

### Official description

DSpace is an open source turnkey repository application. In version 7.0, any community or collection administrator can escalate their permission up to become system administrator. This vulnerability only exists in 7.0 and does not impact 6.x or below. This issue is patched in version 7.1. As a workaround, users of 7.0 may temporarily disable the ability for community or collection administrators to manage permissions or workflows settings.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-41189?

2 open source packages ship an affected version, including org.dspace:dspace-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dspace:dspace-api` | Maven | From 7.0 | 7.1 |
| `org.dspace:dspace-api` | Maven | From 7.0 | 7.1 |

Products: Duraspace Dspace.

## How do I fix CVE-2021-41189?

Upgrade org.dspace:dspace-api to 7.1 or later.

## Is CVE-2021-41189 being exploited?

There is no known exploitation of CVE-2021-41189 in the wild and no public exploit code.

## Other vulnerabilities in DSpace

- [CVE-2022-31194](https://insights.sbomify.com/CVE-2022-31194/): Path traversal vulnerabilities in DSpace JSPUI submission upload (high 8.2)
- [CVE-2016-10726](https://insights.sbomify.com/CVE-2016-10726/): High severity vulnerability that affects org.dspace:dspace-xmlui (high 7.5)
- [CVE-2022-31195](https://insights.sbomify.com/CVE-2022-31195/): Path traversal vulnerability in Simple Archive Format package import in DSpace (high 7.2)
- [CVE-2022-31191](https://insights.sbomify.com/CVE-2022-31191/): Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools (high 7.1)
- [CVE-2022-31192](https://insights.sbomify.com/CVE-2022-31192/): Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41189 and fix it if it is affected.

What it is: CVE-2021-41189 is a high-severity vulnerability in DSpace, published on 29 Oct 2021. 
Exploitation: There is no known exploitation of CVE-2021-41189 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dspace:dspace-api (Maven): affected from 7.0; fixed in 7.1
- org.dspace:dspace-api (Maven): affected from 7.0; fixed in 7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41189/ (Markdown: https://insights.sbomify.com/CVE-2021-41189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41189
- OSV: https://osv.dev/vulnerability/CVE-2021-41189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41189/
Summaries are generated and may contain mistakes; the official description above is the record.
