{"answers":{"affected":"2 open source packages ship an affected version, including com.wire:avs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41193 in the wild and no public exploit code.","fix":"Upgrade com.wire:avs to 7.1.12 or later.","what":"CVE-2021-41193 is a critical vulnerability in wireapp wire-avs, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41193 and fix it if it is affected.\n\nWhat it is: CVE-2021-41193 is a critical vulnerability in wireapp wire-avs, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41193 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.wire:avs (Maven): affected all versions; fixed in 7.1.12\n- com.wire:avs (Maven): affected all versions; fixed in 7.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41193/ (Markdown: https://insights.sbomify.com/CVE-2021-41193/index.md)","id":"CVE-2021-41193","markdown":"https://insights.sbomify.com/CVE-2021-41193/index.md","name":"CVE-2021-41193","record":{"aliases":["GHSA-2j6v-xpf3-xvrv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Wire AVS library","requires_auth":"none","summary":"A remote format string vulnerability in the Wire AVS library allows attackers to cause denial of service or execute arbitrary code.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wire-audio_video_signaling","vendor":"wire"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"wire-avs is the audio visual signaling (AVS) component of Wire, an open-source messenger. A remote format string vulnerability in versions prior to 7.1.12 allows an attacker to cause a denial of service or possibly execute arbitrary code. The issue has been fixed in wire-avs 7.1.12. There are currently no known workarounds.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of Externally-Controlled Format String in wire-avs","id":"CVE-2021-41193","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Access Control in jupyterhub-firstuseauthenticator","id":"CVE-2021-41194"},"packages":[{"ecosystem":"Maven","fixed":["7.1.12"],"introduced":["0"],"last_affected":[],"package":"com.wire:avs","purl":null,"source":"GHSA-2j6v-xpf3-xvrv"},{"ecosystem":"Maven","fixed":["7.1.12"],"introduced":["0"],"last_affected":[],"package":"com.wire:avs","purl":"pkg:maven/com.wire/avs","source":"GHSA-2j6v-xpf3-xvrv"}],"prev":{"headline":"Insecure default configuration","id":"CVE-2021-41192"},"products":["wire-avs"],"published":"2022-03-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["wireapp"]},"summary":"A remote format string vulnerability in the Wire AVS library allows attackers to cause denial of service or execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2021-41193/"}