# CVE-2021-41193: Use of Externally-Controlled Format String in wire-avs

> A remote format string vulnerability in the Wire AVS library allows attackers to cause denial of service or execute arbitrary code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2j6v-xpf3-xvrv

## What is CVE-2021-41193?

CVE-2021-41193 is a critical vulnerability in wireapp wire-avs, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

wire-avs is the audio visual signaling (AVS) component of Wire, an open-source messenger. A remote format string vulnerability in versions prior to 7.1.12 allows an attacker to cause a denial of service or possibly execute arbitrary code. The issue has been fixed in wire-avs 7.1.12. There are currently no known workarounds.

Weakness: CWE-134 (Use of Externally-Controlled Format String)

## Which versions are affected by CVE-2021-41193?

2 open source packages ship an affected version, including com.wire:avs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.wire:avs` | Maven | All versions | 7.1.12 |
| `com.wire:avs` | Maven | All versions | 7.1.12 |

Products: Wire Wire-Audio Video Signaling.

## How do I fix CVE-2021-41193?

Upgrade com.wire:avs to 7.1.12 or later.

## Is CVE-2021-41193 being exploited?

There is no known exploitation of CVE-2021-41193 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41193 and fix it if it is affected.

What it is: CVE-2021-41193 is a critical vulnerability in wireapp wire-avs, published on 1 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41193 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.wire:avs (Maven): affected all versions; fixed in 7.1.12
- com.wire:avs (Maven): affected all versions; fixed in 7.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41193/ (Markdown: https://insights.sbomify.com/CVE-2021-41193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41193
- OSV: https://osv.dev/vulnerability/CVE-2021-41193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41193/
Summaries are generated and may contain mistakes; the official description above is the record.
