{"answers":{"affected":"3 open source packages ship an affected version, including jupyterhub-firstuseauthenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41194 in the wild and no public exploit code.","fix":"Upgrade jupyterhub-firstuseauthenticator to 1.0.0 or later.","what":"CVE-2021-41194 is a critical authentication bypass vulnerability in jupyterhub firstuseauthenticator, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41194 and fix it if it is affected.\n\nWhat it is: CVE-2021-41194 is a critical authentication bypass vulnerability in jupyterhub firstuseauthenticator, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41194 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0\n- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0\n- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41194/ (Markdown: https://insights.sbomify.com/CVE-2021-41194/index.md)","id":"CVE-2021-41194","markdown":"https://insights.sbomify.com/CVE-2021-41194/index.md","name":"CVE-2021-41194","record":{"aliases":["GHSA-5xvc-vgmp-jgc3","PYSEC-2021-384"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterHub authenticator","requires_auth":"none","summary":"Attackers can gain unauthorized access to user accounts in JupyterHub if user creation is enabled and usernames are known.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"first_use_authenticator","vendor":"jupyterhub"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"FirstUseAuthenticator is a JupyterHub authenticator that helps new users set their password on their first login to JupyterHub. When JupyterHub is used with FirstUseAuthenticator, a vulnerability in versions prior to 1.0.0 allows unauthorized access to any user's account if `create_users=True` and the username is known or guessed. One may upgrade to version 1.0.0 or apply a patch manually to mitigate the vulnerability. For those who cannot upgrade, there is no complete workaround, but a partial mitigation exists. One can disable user creation with `c.FirstUseAuthenticator.create_users = False`, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until a patch or upgrade occurs.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Access Control in jupyterhub-firstuseauthenticator","id":"CVE-2021-41194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Crash in `tf.math.segment_*` operations","id":"CVE-2021-41195"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"jupyterhub-firstuseauthenticator","purl":null,"source":"GHSA-5xvc-vgmp-jgc3"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"jupyterhub-firstuseauthenticator","purl":"pkg:pypi/jupyterhub-firstuseauthenticator","source":"GHSA-5xvc-vgmp-jgc3"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"jupyterhub-firstuseauthenticator","purl":"pkg:pypi/jupyterhub-firstuseauthenticator","source":"PYSEC-2021-384"}],"prev":{"headline":"Use of Externally-Controlled Format String in wire-avs","id":"CVE-2021-41193"},"products":["firstuseauthenticator"],"published":"2021-10-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["jupyterhub"]},"summary":"Attackers can gain unauthorized access to user accounts in JupyterHub if user creation is enabled and usernames are known.","url":"https://insights.sbomify.com/CVE-2021-41194/"}