# CVE-2021-41194: Improper Access Control in jupyterhub-firstuseauthenticator

> Attackers can gain unauthorized access to user accounts in JupyterHub if user creation is enabled and usernames are known.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5xvc-vgmp-jgc3, PYSEC-2021-384

## What is CVE-2021-41194?

CVE-2021-41194 is a critical authentication bypass vulnerability in jupyterhub firstuseauthenticator, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FirstUseAuthenticator is a JupyterHub authenticator that helps new users set their password on their first login to JupyterHub. When JupyterHub is used with FirstUseAuthenticator, a vulnerability in versions prior to 1.0.0 allows unauthorized access to any user's account if `create_users=True` and the username is known or guessed. One may upgrade to version 1.0.0 or apply a patch manually to mitigate the vulnerability. For those who cannot upgrade, there is no complete workaround, but a partial mitigation exists. One can disable user creation with `c.FirstUseAuthenticator.create_users = False`, which will only allow login with fully normalized usernames for already existing users prior to jupyterhub-firstuserauthenticator 1.0.0. If any users have never logged in with their normalized username (i.e. lowercase), they will still be vulnerable until a patch or upgrade occurs.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2021-41194?

3 open source packages ship an affected version, including jupyterhub-firstuseauthenticator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub-firstuseauthenticator` | PyPI | All versions | 1.0.0 |
| `jupyterhub-firstuseauthenticator` | PyPI | All versions | 1.0.0 |
| `jupyterhub-firstuseauthenticator` | PyPI | All versions | 1.0.0 |

Products: Jupyterhub First Use Authenticator.

## How do I fix CVE-2021-41194?

Upgrade jupyterhub-firstuseauthenticator to 1.0.0 or later.

## Is CVE-2021-41194 being exploited?

There is no known exploitation of CVE-2021-41194 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41194 and fix it if it is affected.

What it is: CVE-2021-41194 is a critical authentication bypass vulnerability in jupyterhub firstuseauthenticator, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41194 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0
- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0
- jupyterhub-firstuseauthenticator (PyPI): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41194/ (Markdown: https://insights.sbomify.com/CVE-2021-41194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41194
- OSV: https://osv.dev/vulnerability/CVE-2021-41194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41194/
Summaries are generated and may contain mistakes; the official description above is the record.
