# CVE-2021-41230: OIDC claims not updated from Identity Provider in Pomerium

> Pomerium fails to update OIDC claims after login, allowing users to bypass authorization policies if their identity provider claims change.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-j6wp-3859-vxfg, GO-2021-0258

## What is CVE-2021-41230?

CVE-2021-41230 is a medium-severity missing authorization vulnerability in pomerium, published on 5 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pomerium is an open source identity-aware access proxy. In affected versions changes to the OIDC claims of a user after initial login are not reflected in policy evaluation when using `allowed_idp_claims` as part of policy. If using `allowed_idp_claims` and a user's claims are changed, Pomerium can make incorrect authorization decisions. This issue has been resolved in v0.15.6. For users unable to upgrade clear data on `databroker` service by clearing redis or restarting the in-memory databroker to force claims to be updated.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-41230?

3 open source packages ship an affected version, including github.com/pomerium/pomerium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pomerium/pomerium` | Go | All versions | 0.15.6 |
| `github.com/pomerium/pomerium` | Go | From 0.14.0 | 0.15.6 |
| `github.com/pomerium/pomerium` | Go | From 0.14.0 | 0.15.6 |

Products: Pomerium Pomerium.

## How do I fix CVE-2021-41230?

Upgrade github.com/pomerium/pomerium to 0.15.6 or later.

## Is CVE-2021-41230 being exploited?

There is no known exploitation of CVE-2021-41230 in the wild and no public exploit code.

## Other vulnerabilities in pomerium

- [CVE-2023-33189](https://insights.sbomify.com/CVE-2023-33189/): Incorrect Authorization with specially crafted requests (critical 10.0)
- [CVE-2022-24797](https://insights.sbomify.com/CVE-2022-24797/): Exposure of Sensitive Information in Pomerium (medium 6.5)
- [CVE-2021-29651](https://insights.sbomify.com/CVE-2021-29651/): JWT leak via Open Redirect in Programmatic access (medium 6.1)
- [CVE-2021-29652](https://insights.sbomify.com/CVE-2021-29652/): pomerium_signature is not verified in middleware in github.com/pomerium/pomerium (medium 6.1)
- [CVE-2024-39315](https://insights.sbomify.com/CVE-2024-39315/): Pomerium exposed OAuth2 access and ID tokens in user info endpoint response (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41230 and fix it if it is affected.

What it is: CVE-2021-41230 is a medium-severity missing authorization vulnerability in pomerium, published on 5 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41230 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pomerium/pomerium (Go): affected all versions; fixed in 0.15.6
- github.com/pomerium/pomerium (Go): affected from 0.14.0; fixed in 0.15.6
- github.com/pomerium/pomerium (Go): affected from 0.14.0; fixed in 0.15.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41230/ (Markdown: https://insights.sbomify.com/CVE-2021-41230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41230
- OSV: https://osv.dev/vulnerability/CVE-2021-41230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41230/
Summaries are generated and may contain mistakes; the official description above is the record.
