CVE-2021-41231 OpenMage LTS DataFlow upload remote code execution vulnerability

High 7.2 Published Updated

Administrators with specific permissions can execute arbitrary code via the DataFlow convert profile in OpenMage LTS.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-41231?

CVE-2021-41231 is a high-severity vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Weakness: CWE-434, CWE-77

Which versions are affected by CVE-2021-41231?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistFrom 20.0.020.0.19
openmage/magento-lts PackagistFrom 20.0.020.0.19

Products include Openmage Magento.

How do I fix CVE-2021-41231?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.

Is CVE-2021-41231 being exploited?

There is no known exploitation of CVE-2021-41231 in the wild and no public exploit code.

Sources

Also known as GHSA-h632-p764-pjqm.

Is CVE-2021-41231 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free