{"answers":{"affected":"4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41231 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.","what":"CVE-2021-41231 is a high-severity vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41231 and fix it if it is affected.\n\nWhat it is: CVE-2021-41231 is a high-severity vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41231 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41231/ (Markdown: https://insights.sbomify.com/CVE-2021-41231/index.md)","id":"CVE-2021-41231","markdown":"https://insights.sbomify.com/CVE-2021-41231/index.md","name":"CVE-2021-41231","record":{"aliases":["GHSA-h632-p764-pjqm"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenMage LTS e-commerce","requires_auth":"high_privilege","summary":"Administrators with specific permissions can execute arbitrary code via the DataFlow convert profile in OpenMage LTS.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"magento","vendor":"openmage"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenMage LTS DataFlow upload remote code execution vulnerability","id":"CVE-2021-41231","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2021"},"n_packages":4,"n_references":4,"next":{"headline":"Improper Neutralization of Special Elements used in an LDAP Query","id":"CVE-2021-41232"},"packages":[{"ecosystem":"Packagist","fixed":["19.4.22"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-h632-p764-pjqm"},{"ecosystem":"Packagist","fixed":["19.4.22"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-h632-p764-pjqm"},{"ecosystem":"Packagist","fixed":["20.0.19"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-h632-p764-pjqm"},{"ecosystem":"Packagist","fixed":["20.0.19"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-h632-p764-pjqm"}],"prev":{"headline":"OIDC claims not updated from Identity Provider in Pomerium","id":"CVE-2021-41230"},"products":["magento-lts"],"published":"2023-01-27","related":[{"cvss_score":9.8,"headline":"Fixes a bug in Zend Framework's Stream HTTP Wrapper","id":"CVE-2021-21426","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":9.1,"headline":"Backport for CVE-2021-21024 Blind SQLi from Magento 2","id":"CVE-2021-21427","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.8,"headline":"OpenMage LTS authenticated remote code execution through layout update","id":"CVE-2021-41144","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":8.7,"headline":"OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution","id":"CVE-2026-40488","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8.1,"headline":"OpenMage LTS's Phar Deserialization leads to Remote Code Execution","id":"CVE-2026-25524","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8,"headline":"RCE in Magento","id":"CVE-2020-15244","kev_date_added":null,"published":"2020-10-21"},{"cvss_score":7.5,"headline":"Magento LTS's guest order \"protect code\" can be brute-forced too easily","id":"CVE-2023-41879","kev_date_added":null,"published":"2023-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["OpenMage"]},"summary":"Administrators with specific permissions can execute arbitrary code via the DataFlow convert profile in OpenMage LTS.","url":"https://insights.sbomify.com/CVE-2021-41231/"}