CVE-2021-41246 Session fixation in express-openid-connect
Attackers can hijack user sessions by exploiting missing session ID regeneration during login in Express OpenID Connect middleware.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-41246?
CVE-2021-41246 is a medium-severity authentication bypass vulnerability in auth0 express-openid-connect, published on 9 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Express OpenID Connect is express JS middleware implementing sign on for Express web apps using OpenID Connect. Versions before and including `2.5.1` do not regenerate the session id and session cookie when user logs in. This behavior opens up the application to various session fixation vulnerabilities. Versions `2.5.2` contains a patch for this issue.
Weakness: CWE-384
Which versions are affected by CVE-2021-41246?
2 open source packages ship an affected version, including express-openid-connect. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
express-openid-connect npm | From 2.3.0 | 2.5.2 |
express-openid-connect npm | From 2.3.0 | 2.5.2 |
Products include Auth0 Express Openid Connect.
How do I fix CVE-2021-41246?
Upgrade express-openid-connect to 2.5.2 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2021-41246 being exploited?
There is no known exploitation of CVE-2021-41246 in the wild and no public exploit code.
Other vulnerabilities in auth0 express-openid-connect
Sources
Also known as GHSA-7rg2-qxmf-hhx9.