# CVE-2021-41246: Session fixation in express-openid-connect

> Attackers can hijack user sessions by exploiting missing session ID regeneration during login in Express OpenID Connect middleware.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7rg2-qxmf-hhx9

## What is CVE-2021-41246?

CVE-2021-41246 is a medium-severity authentication bypass vulnerability in auth0 express-openid-connect, published on 9 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Express OpenID Connect is express JS middleware implementing sign on for Express web apps using OpenID Connect. Versions before and including `2.5.1` do not regenerate the session id and session cookie when user logs in. This behavior opens up the application to various session fixation vulnerabilities. Versions `2.5.2` contains a patch for this issue.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2021-41246?

2 open source packages ship an affected version, including express-openid-connect. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-openid-connect` | npm | From 2.3.0 | 2.5.2 |
| `express-openid-connect` | npm | From 2.3.0 | 2.5.2 |

Products: Auth0 Express Openid Connect.

## How do I fix CVE-2021-41246?

Upgrade express-openid-connect to 2.5.2 or later.

## Is CVE-2021-41246 being exploited?

There is no known exploitation of CVE-2021-41246 in the wild and no public exploit code.

## Other vulnerabilities in auth0 express-openid-connect

- [CVE-2022-24794](https://insights.sbomify.com/CVE-2022-24794/): Open Redirect in express-openid-connect (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41246 and fix it if it is affected.

What it is: CVE-2021-41246 is a medium-severity authentication bypass vulnerability in auth0 express-openid-connect, published on 9 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41246 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-openid-connect (npm): affected from 2.3.0; fixed in 2.5.2
- express-openid-connect (npm): affected from 2.3.0; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41246/ (Markdown: https://insights.sbomify.com/CVE-2021-41246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41246
- OSV: https://osv.dev/vulnerability/CVE-2021-41246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41246/
Summaries are generated and may contain mistakes; the official description above is the record.
