# CVE-2021-41247: incomplete logout in JupyterHub

> Attackers can retain access to single-user servers after logout if multiple tabs are open, bypassing session termination controls.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-jupyterhub-2021-41247, DEBIAN-CVE-2021-41247, GHSA-cw7p-q79f-m2v7, PYSEC-2021-386

## What is CVE-2021-41247?

CVE-2021-41247 is a low-severity vulnerability in jupyterhub, published on 4 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

JupyterHub is an open source multi-user server for Jupyter notebooks. In affected versions users who have multiple JupyterLab tabs open in the same browser session, may see incomplete logout from the single-user server, as fresh credentials (for the single-user server only, not the Hub) reinstated after logout, if another active JupyterLab session is open while the logout takes place. Upgrade to JupyterHub 1.5. For distributed deployments, it is jupyterhub in the _user_ environment that needs patching. There are no patches necessary in the Hub environment. The only workaround is to make sure that only one JupyterLab tab is open when you log out.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2021-41247?

4 open source packages ship an affected version, including jupyterhub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterhub` | Bitnami | From 1.0.0 | 1.5.0 |
| `jupyterhub` | PyPI | From 1.0.0 | 1.5.0 |
| `jupyterhub` | PyPI | From 1.0.0 | 1.5.0 |
| `jupyterhub` | PyPI | From 1.0.0 | 1.5.0 |

Products: Jupyter Jupyterhub.

## How do I fix CVE-2021-41247?

Upgrade jupyterhub to 1.5.0 or later.

## Is CVE-2021-41247 being exploited?

There is no known exploitation of CVE-2021-41247 in the wild and no public exploit code.

## Other vulnerabilities in jupyterhub

- [CVE-2024-28233](https://insights.sbomify.com/CVE-2024-28233/): XSS in JupyterHub via Self-XSS leveraged by Cookie Tossing (high 8.1)
- [CVE-2024-41942](https://insights.sbomify.com/CVE-2024-41942/): JupyterHub has a privilege escalation vulnerability with the `admin:users` scope (high 7.2)
- [CVE-2019-10255](https://insights.sbomify.com/CVE-2019-10255/): Open Redirect vulnerability in jupyterhub and notebook (medium 6.1)
- [CVE-2026-40864](https://insights.sbomify.com/CVE-2026-40864/): JupyterHub: Cross-origin form POSTs bypass XSRF (medium 5.4)
- [CVE-2026-33709](https://insights.sbomify.com/CVE-2026-33709/): JupyterHub has an Open Redirect Vulnerability (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41247 and fix it if it is affected.

What it is: CVE-2021-41247 is a low-severity vulnerability in jupyterhub, published on 4 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-41247 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterhub (Bitnami): affected from 1.0.0; fixed in 1.5.0
- jupyterhub (PyPI): affected from 1.0.0; fixed in 1.5.0
- jupyterhub (PyPI): affected from 1.0.0; fixed in 1.5.0
- jupyterhub (PyPI): affected from 1.0.0; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41247/ (Markdown: https://insights.sbomify.com/CVE-2021-41247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41247
- OSV: https://osv.dev/vulnerability/CVE-2021-41247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41247/
Summaries are generated and may contain mistakes; the official description above is the record.
