{"answers":{"affected":"2 open source packages ship an affected version, including graphql-playground-react. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41249 in the wild and no public exploit code.","fix":"Upgrade graphql-playground-react to 1.7.28 or later.","what":"CVE-2021-41249 is a high-severity cross-site scripting vulnerability in graphql-playground, published on 4 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-41249 and fix it if it is affected.\n\nWhat it is: CVE-2021-41249 is a high-severity cross-site scripting vulnerability in graphql-playground, published on 4 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-41249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- graphql-playground-react (npm): affected all versions; fixed in 1.7.28\n- graphql-playground-react (npm): affected all versions; fixed in 1.7.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41249/ (Markdown: https://insights.sbomify.com/CVE-2021-41249/index.md)","id":"CVE-2021-41249","markdown":"https://insights.sbomify.com/CVE-2021-41249/index.md","name":"CVE-2021-41249","record":{"aliases":["GHSA-59r9-6jp6-jcm7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL IDE library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in users' browsers via malicious GraphQL schemas, potentially stealing credentials.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"playground","vendor":"graphql"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GraphQL Playground is a GraphQL IDE for development of graphQL focused applications. All versions of graphql-playground-react older than graphql-playground-react@1.7.28 are vulnerable to compromised HTTP schema introspection responses or schema prop values with malicious GraphQL type names, exposing a dynamic XSS attack surface that can allow code injection on operation autocomplete. In order for the attack to take place, the user must load a malicious schema in graphql-playground. There are several ways this can occur, including by specifying the URL to a malicious schema in the endpoint query parameter. If a user clicks on a link to a GraphQL Playground installation that specifies a malicious server, arbitrary JavaScript can run in the user's browser, which can be used to exfiltrate user credentials or other harmful goals. If you are using graphql-playground-react directly in your client app, upgrade to version 1.7.28 or later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS vulnerability in GraphQL Playground","id":"CVE-2021-41249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Presence of non-blacklisted URL bypasses all other filters","id":"CVE-2021-41250"},"packages":[{"ecosystem":"npm","fixed":["1.7.28"],"introduced":["0"],"last_affected":[],"package":"graphql-playground-react","purl":null,"source":"GHSA-59r9-6jp6-jcm7"},{"ecosystem":"npm","fixed":["1.7.28"],"introduced":["0"],"last_affected":[],"package":"graphql-playground-react","purl":"pkg:npm/graphql-playground-react","source":"GHSA-59r9-6jp6-jcm7"}],"prev":{"headline":"XSS vulnerability in GraphiQL","id":"CVE-2021-41248"},"products":["graphql-playground"],"published":"2021-11-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["graphql"]},"summary":"Attackers can execute arbitrary JavaScript in users' browsers via malicious GraphQL schemas, potentially stealing credentials.","url":"https://insights.sbomify.com/CVE-2021-41249/"}