# CVE-2021-41251: Possibility to elevate privileges or get unauthorized access to data

> Attackers can access unauthorized destination data and permissions when caching is enabled and user info is missing in SAP Cloud SDK.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gp2f-254m-rh32

## What is CVE-2021-41251?

CVE-2021-41251 is a medium-severity vulnerability in SAP cloud-sdk-js, published on 5 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@sap-cloud-sdk/core contains the core functionality of the SAP Cloud SDK as well as the SAP Business Technology Platform abstractions. This affects applications on SAP Business Technology Platform that use the SAP Cloud SDK and enabled caching of destinations. In affected versions and in some cases, when user information was missing, destinations were cached without user information, allowing other users to retrieve the same destination with its permissions. By default, destination caching is disabled. The security for caching has been increased. The changes are released in version 1.52.0. Users unable to upgrade are advised to disable destination caching (it is disabled by default).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-41251?

2 open source packages ship an affected version, including @sap-cloud-sdk/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sap-cloud-sdk/core` | npm | All versions | 1.52.0 |
| `@sap-cloud-sdk/core` | npm | All versions | 1.52.0 |

Products: Sap Cloud Sdk.

## How do I fix CVE-2021-41251?

Upgrade @sap-cloud-sdk/core to 1.52.0 or later.

## Is CVE-2021-41251 being exploited?

There is no known exploitation of CVE-2021-41251 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41251 and fix it if it is affected.

What it is: CVE-2021-41251 is a medium-severity vulnerability in SAP cloud-sdk-js, published on 5 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41251 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sap-cloud-sdk/core (npm): affected all versions; fixed in 1.52.0
- @sap-cloud-sdk/core (npm): affected all versions; fixed in 1.52.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41251/ (Markdown: https://insights.sbomify.com/CVE-2021-41251/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41251
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41251
- OSV: https://osv.dev/vulnerability/CVE-2021-41251

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41251/
Summaries are generated and may contain mistakes; the official description above is the record.
