CVE-2021-41252 Cross-site scripting (XSS) from writer field content in the site frontend

High 7.3 Published Updated

Authenticated attackers can inject malicious scripts via the writer field, leading to XSS execution in victim browsers and potential API abuse.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-41252?

CVE-2021-41252 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 16 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Kirby is an open source file structured CMS ### Impact Kirby's writer field stores its formatted content as HTML code. Unlike with other field types, it is not possible to escape HTML special characters against cross-site scripting (XSS) attacks, otherwise the formatting would be lost. If the user is logged in to the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. Because the writer field did not securely sanitize its contents on save, it was possible to inject malicious HTML code into the content file by sending it to Kirby's API directly without using the Panel. This malicious HTML code would then be displayed on the site frontend and executed in the browsers of site visitors and logged in users who are browsing the site. Attackers must be in your group of authenticated Panel users in order to exploit this weakness. Users who do not make use of the writer field are not affected. This issue has been patched in Kirby 3.5.8 by sanitizing all writer field contents on the backend whenever the content is modified via Kirby's API. Please update to this or a later version to fix the vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2021-41252?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.

PackageAffectedFixed in
getkirby/cms PackagistFrom 3.5.03.5.8
getkirby/cms PackagistFrom 3.5.03.5.8

Products include Getkirby Kirby.

How do I fix CVE-2021-41252?

Upgrade getkirby/cms to 3.5.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-41252 being exploited?

There is no known exploitation of CVE-2021-41252 in the wild and no public exploit code.

Sources

Also known as GHSA-x7j7-qp7j-hw3q.

Is CVE-2021-41252 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free