CVE-2021-41258 Cross-site scripting (XSS) from image block content in the site frontend

High 7.3 Published Updated

Authenticated users can inject malicious HTML into image blocks, leading to XSS execution in site visitors' browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-41258?

CVE-2021-41258 is a high-severity cross-site scripting vulnerability in getkirby kirby, published on 16 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Kirby is an open source file structured CMS. In affected versions Kirby's blocks field stores structured data for each block. This data is then used in block snippets to convert the blocks to HTML for use in your templates. We recommend to escape HTML special characters to protect against cross-site scripting (XSS) attacks. The default snippet for the image block unfortunately did not use our escaping helper. This made it possible to include malicious HTML code in the source, alt and link fields of the image block, which would then be displayed on the site frontend and executed in the browsers of site visitors and logged in users who are browsing the site. Attackers must be in your group of authenticated Panel users in order to exploit this weakness. Users who do not make use of the blocks field are not affected. This issue has been patched in Kirby version 3.5.8 by escaping special HTML characters in the output from the default image block snippet. Please update to this or a later version to fix the vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2021-41258?

2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.

PackageAffectedFixed in
getkirby/cms PackagistFrom 3.5.03.5.8
getkirby/cms PackagistFrom 3.5.03.5.8

Products include Getkirby Kirby.

How do I fix CVE-2021-41258?

Upgrade getkirby/cms to 3.5.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-41258 being exploited?

There is no known exploitation of CVE-2021-41258 in the wild and no public exploit code.

Sources

Also known as GHSA-cq58-r77c-5jjw.

Is CVE-2021-41258 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free