# CVE-2021-41262: SQL Injection in Galette

> Authenticated members can execute SQL injection attacks in Galette, potentially reading or modifying database contents.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-936f-xvgq-fg74, UBUNTU-CVE-2021-41262

## What is CVE-2021-41262?

CVE-2021-41262 is a high-severity SQL injection vulnerability in galette, published on 16 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Galette is a membership management web application built for non profit organizations and released under GPLv3. Versions prior to 0.9.6 are subject to SQL injection attacks by users with "member" privilege. Users are advised to upgrade to version 0.9.6 as soon as possible. There are no known workarounds.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2021-41262?

It affects 1 product.


Products: Galette Galette.

## How do I fix CVE-2021-41262?

No fix has been published for CVE-2021-41262 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-41262 being exploited?

There is no known exploitation of CVE-2021-41262 in the wild and no public exploit code.

## Other vulnerabilities in galette

- [CVE-2021-41260](https://insights.sbomify.com/CVE-2021-41260/): Missing CSRF checks in Galette (high 8.2)
- [CVE-2021-41261](https://insights.sbomify.com/CVE-2021-41261/): Stored Cross-site Scripting in Galette (high 8.1)
- [CVE-2024-24761](https://insights.sbomify.com/CVE-2024-24761/): Galette public pages accessibility restriction (high 7.5)
- [CVE-2021-21319](https://insights.sbomify.com/CVE-2021-21319/): Several stored XSS (medium 6.8)
- [CVE-2025-48076](https://insights.sbomify.com/CVE-2025-48076/): Galette is vulnerable to Cross-site Scripting (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41262 and fix it if it is affected.

What it is: CVE-2021-41262 is a high-severity SQL injection vulnerability in galette, published on 16 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41262 in the wild and no public exploit code.

Affected product: galette. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41262/ (Markdown: https://insights.sbomify.com/CVE-2021-41262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41262
- OSV: https://osv.dev/vulnerability/CVE-2021-41262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41262/
Summaries are generated and may contain mistakes; the official description above is the record.
