{"answers":{"affected":"2 open source packages ship an affected version, including rails_multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41263 in the wild and no public exploit code.","fix":"Upgrade rails_multisite to 4.0.0 or later.","what":"CVE-2021-41263 is a high-severity vulnerability in discourse rails_multisite, published on 15 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41263 and fix it if it is affected.\n\nWhat it is: CVE-2021-41263 is a high-severity vulnerability in discourse rails_multisite, published on 15 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41263 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails_multisite (RubyGems): affected all versions; fixed in 4.0.0\n- rails_multisite (RubyGems): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41263/ (Markdown: https://insights.sbomify.com/CVE-2021-41263/index.md)","id":"CVE-2021-41263","markdown":"https://insights.sbomify.com/CVE-2021-41263/index.md","name":"CVE-2021-41263","record":{"aliases":["GHSA-844m-cpr9-jcmh"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Rails library","requires_auth":"low_privilege","summary":"Attackers can reuse signed cookies across different sites in multi-site Rails apps due to shared secrets, bypassing security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"rails_multisite","vendor":"discourse"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"},{"id":"CWE-565","name":"Reliance on Cookies without Validation and Integrity Checking"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"rails_multisite provides multi-db support for Rails applications. In affected versions this vulnerability impacts any Rails applications using `rails_multisite` alongside Rails' signed/encrypted cookies. Depending on how the application makes use of these cookies, it may be possible for an attacker to re-use cookies on different 'sites' within a multi-site Rails application. The issue has been patched in v4 of the `rails_multisite` gem. Note that this upgrade will invalidate all previous signed/encrypted cookies. The impact of this invalidation will vary based on the application architecture.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Secure/signed cookies share secrets between sites in rails_multisite","id":"CVE-2021-41263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","id":"CVE-2021-41264"},"packages":[{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"rails_multisite","purl":null,"source":"GHSA-844m-cpr9-jcmh"},{"ecosystem":"RubyGems","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"rails_multisite","purl":"pkg:gem/rails_multisite","source":"GHSA-844m-cpr9-jcmh"}],"prev":{"headline":"SQL Injection in Galette","id":"CVE-2021-41262"},"products":["rails_multisite"],"published":"2021-11-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["discourse"]},"summary":"Attackers can reuse signed cookies across different sites in multi-site Rails apps due to shared secrets, bypassing security controls.","url":"https://insights.sbomify.com/CVE-2021-41263/"}