# CVE-2021-41263: Secure/signed cookies share secrets between sites in rails_multisite

> Attackers can reuse signed cookies across different sites in multi-site Rails apps due to shared secrets, bypassing security controls.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-844m-cpr9-jcmh

## What is CVE-2021-41263?

CVE-2021-41263 is a high-severity vulnerability in discourse rails_multisite, published on 15 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

rails_multisite provides multi-db support for Rails applications. In affected versions this vulnerability impacts any Rails applications using `rails_multisite` alongside Rails' signed/encrypted cookies. Depending on how the application makes use of these cookies, it may be possible for an attacker to re-use cookies on different 'sites' within a multi-site Rails application. The issue has been patched in v4 of the `rails_multisite` gem. Note that this upgrade will invalidate all previous signed/encrypted cookies. The impact of this invalidation will vary based on the application architecture.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm), CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-41263?

2 open source packages ship an affected version, including rails_multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails_multisite` | RubyGems | All versions | 4.0.0 |
| `rails_multisite` | RubyGems | All versions | 4.0.0 |

Products: Discourse Rails Multisite.

## How do I fix CVE-2021-41263?

Upgrade rails_multisite to 4.0.0 or later.

## Is CVE-2021-41263 being exploited?

There is no known exploitation of CVE-2021-41263 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41263 and fix it if it is affected.

What it is: CVE-2021-41263 is a high-severity vulnerability in discourse rails_multisite, published on 15 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41263 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails_multisite (RubyGems): affected all versions; fixed in 4.0.0
- rails_multisite (RubyGems): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41263/ (Markdown: https://insights.sbomify.com/CVE-2021-41263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41263
- OSV: https://osv.dev/vulnerability/CVE-2021-41263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41263/
Summaries are generated and may contain mistakes; the official description above is the record.
