{"answers":{"affected":"4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41264 in the wild and no public exploit code.","fix":"Upgrade @openzeppelin/contracts to 4.3.2 or later.","what":"CVE-2021-41264 is a critical missing authorization vulnerability in openzeppelin-contracts, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41264 and fix it if it is affected.\n\nWhat it is: CVE-2021-41264 is a critical missing authorization vulnerability in openzeppelin-contracts, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41264 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.3.2\n- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.3.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41264/ (Markdown: https://insights.sbomify.com/CVE-2021-41264/index.md)","id":"CVE-2021-41264","markdown":"https://insights.sbomify.com/CVE-2021-41264/index.md","name":"CVE-2021-41264","record":{"aliases":["GHSA-5vp3-v4hc-gx76"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Smart contract library","requires_auth":"none","summary":"Attackers can hijack uninitialized UUPS implementation contracts to gain control, affecting developers using OpenZeppelin Contracts.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"contracts","vendor":"openzeppelin"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-665","name":"Improper Initialization"}],"description":"OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","id":"CVE-2021-41264","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":4,"n_references":3,"next":{"headline":"Improper Authentication in Flask-AppBuilder","id":"CVE-2021-41265"},"packages":[{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":null,"source":"GHSA-5vp3-v4hc-gx76"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":"pkg:npm/%40openzeppelin/contracts","source":"GHSA-5vp3-v4hc-gx76"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":null,"source":"GHSA-5vp3-v4hc-gx76"},{"ecosystem":"npm","fixed":["4.3.2"],"introduced":["4.1.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":"pkg:npm/%40openzeppelin/contracts-upgradeable","source":"GHSA-5vp3-v4hc-gx76"}],"prev":{"headline":"Secure/signed cookies share secrets between sites in rails_multisite","id":"CVE-2021-41263"},"products":["openzeppelin-contracts"],"published":"2021-11-12","related":[{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39167","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39168","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":7.9,"headline":"ECDSA signature malleability in OpenZeppelin Contracts","id":"CVE-2022-35961","kev_date_added":null,"published":"2022-08-14"},{"cvss_score":7.5,"headline":"GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts","id":"CVE-2022-31198","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.5,"headline":"OpenZeppelin Contracts's ERC165Checker may revert instead of returning false","id":"CVE-2022-31170","kev_date_added":null,"published":"2022-07-21"},{"cvss_score":7.5,"headline":"OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers","id":"CVE-2022-31172","kev_date_added":null,"published":"2022-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["OpenZeppelin"]},"summary":"Attackers can hijack uninitialized UUPS implementation contracts to gain control, affecting developers using OpenZeppelin Contracts.","url":"https://insights.sbomify.com/CVE-2021-41264/"}