# CVE-2021-41264: UUPSUpgradeable vulnerability in OpenZeppelin Contracts

> Attackers can hijack uninitialized UUPS implementation contracts to gain control, affecting developers using OpenZeppelin Contracts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5vp3-v4hc-gx76

## What is CVE-2021-41264?

CVE-2021-41264 is a critical missing authorization vulnerability in openzeppelin-contracts, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).

Weakness: CWE-665 (Improper Initialization)

## Which versions are affected by CVE-2021-41264?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.3.2 |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.3.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.3.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.3.2 |

Products: Openzeppelin Contracts.

## How do I fix CVE-2021-41264?

Upgrade @openzeppelin/contracts to 4.3.2 or later.

## Is CVE-2021-41264 being exploited?

There is no known exploitation of CVE-2021-41264 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)
- [CVE-2022-31170](https://insights.sbomify.com/CVE-2022-31170/): OpenZeppelin Contracts's ERC165Checker may revert instead of returning false (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41264 and fix it if it is affected.

What it is: CVE-2021-41264 is a critical missing authorization vulnerability in openzeppelin-contracts, published on 12 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41264 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.3.2
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.3.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41264/ (Markdown: https://insights.sbomify.com/CVE-2021-41264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41264
- OSV: https://osv.dev/vulnerability/CVE-2021-41264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41264/
Summaries are generated and may contain mistakes; the official description above is the record.
