# CVE-2021-41265: Improper Authentication in Flask-AppBuilder

> Attackers can bypass authentication to access protected REST API endpoints in Flask-AppBuilder when using non-database authentication types.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m3rf-7m4w-r66q, PYSEC-2021-851

## What is CVE-2021-41265?

CVE-2021-41265 is a high-severity authentication bypass vulnerability in dpgaspar Flask-AppBuilder, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-41265?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 3.3.4 |
| `flask-appbuilder` | PyPI | All versions | 3.3.4 |
| `Flask-AppBuilder` | PyPI | All versions | 3.3.4 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2021-41265?

Upgrade flask-appbuilder to 3.3.4 or later.

## Is CVE-2021-41265 being exploited?

There is no known exploitation of CVE-2021-41265 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)
- [CVE-2022-24776](https://insights.sbomify.com/CVE-2022-24776/): Open Redirect in Flask-AppBuilder (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41265 and fix it if it is affected.

What it is: CVE-2021-41265 is a high-severity authentication bypass vulnerability in dpgaspar Flask-AppBuilder, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41265 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 3.3.4
- flask-appbuilder (PyPI): affected all versions; fixed in 3.3.4
- Flask-AppBuilder (PyPI): affected all versions; fixed in 3.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41265/ (Markdown: https://insights.sbomify.com/CVE-2021-41265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41265
- OSV: https://osv.dev/vulnerability/CVE-2021-41265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41265/
Summaries are generated and may contain mistakes; the official description above is the record.
