{"answers":{"affected":"5 open source packages ship an affected version, including symfony/security-bundle, symfony and symfony/symfony. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-41268 in the wild and no public exploit code.","fix":"Upgrade symfony/security-bundle to 5.3.12 or later.","what":"CVE-2021-41268 is a medium-severity vulnerability in Sensiolabs Symfony, published on 24 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-41268 and fix it if it is affected.\n\nWhat it is: CVE-2021-41268 is a medium-severity vulnerability in Sensiolabs Symfony, published on 24 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-41268 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- symfony/security-bundle (Packagist): affected from 5.3.0; fixed in 5.3.12\n- symfony/security-bundle (Packagist): affected from 5.3.0; fixed in 5.3.12\n- symfony (Bitnami): affected from 5.3.0; fixed in 5.3.12\n- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.12\n- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-41268/ (Markdown: https://insights.sbomify.com/CVE-2021-41268/index.md)","id":"CVE-2021-41268","markdown":"https://insights.sbomify.com/CVE-2021-41268/index.md","name":"CVE-2021-41268","record":{"aliases":["BIT-symfony-2021-41268","GHSA-qw36-p97w-vcqr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony SecurityBundle","requires_auth":"low_privilege","summary":"Attackers maintain account access via persistent remember-me cookies even after password changes, requiring an upgrade to invalidate cookies on password updates.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"symfony","vendor":"sensiolabs"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"Symfony/SecurityBundle is the security system for Symfony, a PHP framework for web and console applications and a set of reusable PHP components. Since the rework of the Remember me cookie in version 5.3.0, the cookie is not invalidated when the user changes their password. Attackers can therefore maintain their access to the account even if the password is changed as long as they have had the chance to login once and get a valid remember me cookie. Starting with version 5.3.12, Symfony makes the password part of the signature by default. In that way, when the password changes, then the cookie is not valid anymore.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cookie persistence in Symfony","id":"CVE-2021-41268","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"sensiolabs:symfony","products":["sensiolabs:symfony"],"type":"security_feature_bypass","year":"2021"},"n_packages":5,"n_references":4,"next":{"headline":"Unauthenticated remote code injection in cron-utils","id":"CVE-2021-41269"},"packages":[{"ecosystem":"Bitnami","fixed":["5.3.12"],"introduced":["5.3.0"],"last_affected":[],"package":"symfony","purl":"pkg:bitnami/symfony","source":"BIT-symfony-2021-41268"},{"ecosystem":"Packagist","fixed":["5.3.12"],"introduced":["5.3.0"],"last_affected":[],"package":"symfony/security-bundle","purl":null,"source":"GHSA-qw36-p97w-vcqr"},{"ecosystem":"Packagist","fixed":["5.3.12"],"introduced":["5.3.0"],"last_affected":[],"package":"symfony/security-bundle","purl":"pkg:composer/symfony/security-bundle","source":"GHSA-qw36-p97w-vcqr"},{"ecosystem":"Packagist","fixed":["5.3.12"],"introduced":["5.3.0"],"last_affected":[],"package":"symfony/symfony","purl":null,"source":"GHSA-qw36-p97w-vcqr"},{"ecosystem":"Packagist","fixed":["5.3.12"],"introduced":["5.3.0"],"last_affected":[],"package":"symfony/symfony","purl":"pkg:composer/symfony/symfony","source":"GHSA-qw36-p97w-vcqr"}],"prev":{"headline":"Webcache Poisoning in Symfony","id":"CVE-2021-41267"},"products":["symfony"],"published":"2021-11-24","related":[{"cvss_score":9.8,"headline":"Improper Input Validation in Symfony","id":"CVE-2019-11325","kev_date_added":null,"published":"2019-11-21"},{"cvss_score":9.8,"headline":"Symfony Incorrect Access Control","id":"CVE-2017-11365","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":9.8,"headline":"Invalid HTTP method overrides allow possible XSS or other attacks in Symfony","id":"CVE-2019-10913","kev_date_added":null,"published":"2019-05-16"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2018-11407","kev_date_added":null,"published":"2018-06-13"},{"cvss_score":9.8,"headline":"Symfony Authentication Bypass","id":"CVE-2016-2403","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":9.1,"headline":"Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator","id":"CVE-2026-45063","kev_date_added":null,"published":"2026-07-14"},{"cvss_score":8.8,"headline":"Symfony: OidcTokenHandler Accepts JWTs Missing aud/iss/exp Claims","id":"CVE-2026-45069","kev_date_added":null,"published":"2026-07-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["symfony"]},"summary":"Attackers maintain account access via persistent remember-me cookies even after password changes, requiring an upgrade to invalidate cookies on password updates.","url":"https://insights.sbomify.com/CVE-2021-41268/"}