# CVE-2021-41268: Cookie persistence in Symfony

> Attackers maintain account access via persistent remember-me cookies even after password changes, requiring an upgrade to invalidate cookies on password updates.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-symfony-2021-41268, GHSA-qw36-p97w-vcqr

## What is CVE-2021-41268?

CVE-2021-41268 is a medium-severity vulnerability in Sensiolabs Symfony, published on 24 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Symfony/SecurityBundle is the security system for Symfony, a PHP framework for web and console applications and a set of reusable PHP components. Since the rework of the Remember me cookie in version 5.3.0, the cookie is not invalidated when the user changes their password. Attackers can therefore maintain their access to the account even if the password is changed as long as they have had the chance to login once and get a valid remember me cookie. Starting with version 5.3.12, Symfony makes the password part of the signature by default. In that way, when the password changes, then the cookie is not valid anymore.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2021-41268?

5 open source packages ship an affected version, including symfony/security-bundle, symfony and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security-bundle` | Packagist | From 5.3.0 | 5.3.12 |
| `symfony/security-bundle` | Packagist | From 5.3.0 | 5.3.12 |
| `symfony` | Bitnami | From 5.3.0 | 5.3.12 |
| `symfony/symfony` | Packagist | From 5.3.0 | 5.3.12 |
| `symfony/symfony` | Packagist | From 5.3.0 | 5.3.12 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2021-41268?

Upgrade symfony/security-bundle to 5.3.12 or later.

## Is CVE-2021-41268 being exploited?

There is no known exploitation of CVE-2021-41268 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-41268 and fix it if it is affected.

What it is: CVE-2021-41268 is a medium-severity vulnerability in Sensiolabs Symfony, published on 24 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-41268 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security-bundle (Packagist): affected from 5.3.0; fixed in 5.3.12
- symfony/security-bundle (Packagist): affected from 5.3.0; fixed in 5.3.12
- symfony (Bitnami): affected from 5.3.0; fixed in 5.3.12
- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.12
- symfony/symfony (Packagist): affected from 5.3.0; fixed in 5.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-41268/ (Markdown: https://insights.sbomify.com/CVE-2021-41268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-41268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-41268
- OSV: https://osv.dev/vulnerability/CVE-2021-41268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-41268/
Summaries are generated and may contain mistakes; the official description above is the record.
